# CVE-2026-35211: Code injection in opencti

> Authenticated users can inject Elasticsearch Painless scripts via GraphQL to cause denial of service and exfiltrate data.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-qpp6-p693-rmm4, PYSEC-2026-3446

## What is CVE-2026-35211?

CVE-2026-35211 is a medium-severity code injection vulnerability in OpenCTI-Platform opencti, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to 7.260401.0, the OpenCTI GraphQL API exposes a script filter operator in its FilterOperator enum that allows any authenticated user with the KNOWLEDGE capability to pass user-supplied Elasticsearch Painless script values directly into search queries without validation or sanitization, allowing computationally expensive scripts to consume cluster CPU resources and degrade or deny service for all users. This issue is fixed in version 7.260401.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-35211?

1 open source package ship an affected version, including pycti. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pycti` | PyPI | All versions | 7.260401.0 |

Products: Citeum Opencti.

## How do I fix CVE-2026-35211?

Upgrade pycti to 7.260401.0 or later.

## Is CVE-2026-35211 being exploited?

There is no known exploitation of CVE-2026-35211 in the wild and no public exploit code.

## Other vulnerabilities in OpenCTI-Platform opencti

- [CVE-2026-27960](https://insights.sbomify.com/CVE-2026-27960/): OpenCTI privilege escalation and unauthenticated access via default admin account (critical 9.8)
- [CVE-2026-39980](https://insights.sbomify.com/CVE-2026-39980/): OpenCTI affected by RCE via notifier template (critical 9.1)
- [CVE-2025-24977](https://insights.sbomify.com/CVE-2025-24977/): OpenCTI has remote code execution and sensitive secrets exposed through web hook (critical 9.1)
- [CVE-2024-26139](https://insights.sbomify.com/CVE-2024-26139/): OpenCTI Authenticated Privilege Escalation (high 8.3)
- [CVE-2024-45404](https://insights.sbomify.com/CVE-2024-45404/): OpenCTI's lack of Rate Limit lead to OTP brute forcing (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35211 and fix it if it is affected.

What it is: CVE-2026-35211 is a medium-severity code injection vulnerability in OpenCTI-Platform opencti, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35211 in the wild and no public exploit code.

Affected packages and fixed versions:
- pycti (PyPI): affected all versions; fixed in 7.260401.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35211/ (Markdown: https://insights.sbomify.com/CVE-2026-35211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35211
- OSV: https://osv.dev/vulnerability/CVE-2026-35211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35211/
Summaries are generated and may contain mistakes; the official description above is the record.
