# CVE-2026-35212: OpenCTI has XSS in the rendering of email-message observable body data

> Attackers can inject malicious scripts via email observable bodies, leading to session theft and CSRF attacks in OpenCTI.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jun 2026
- **Updated:** 3 Jun 2026
- **Also known as:** GHSA-rg6r-x26x-63vq, PYSEC-2026-203

## What is CVE-2026-35212?

CVE-2026-35212 is a medium-severity cross-site scripting vulnerability in OpenCTI-Platform opencti, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Versions prior to 7.260227.0 are vulnerable to XSS in the rendering of email-message observable body data. The content of the body field isn't appropriately sanitized when being rendered. Does require user interaction but could be exploited by someone sharing stix or any of the ingester. This could lead to CSRF and then large scale session theft. Version 7.260227.0 contains a fix.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-35212?

1 open source package ship an affected version, including pycti. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pycti` | PyPI | All versions | 7.260227.0 |

Products: Citeum Opencti.

## How do I fix CVE-2026-35212?

Upgrade pycti to 7.260227.0 or later.

## Is CVE-2026-35212 being exploited?

There is no known exploitation of CVE-2026-35212 in the wild and no public exploit code.

## Other vulnerabilities in OpenCTI-Platform opencti

- [CVE-2026-27960](https://insights.sbomify.com/CVE-2026-27960/): OpenCTI privilege escalation and unauthenticated access via default admin account (critical 9.8)
- [CVE-2026-39980](https://insights.sbomify.com/CVE-2026-39980/): OpenCTI affected by RCE via notifier template (critical 9.1)
- [CVE-2025-24977](https://insights.sbomify.com/CVE-2025-24977/): OpenCTI has remote code execution and sensitive secrets exposed through web hook (critical 9.1)
- [CVE-2024-26139](https://insights.sbomify.com/CVE-2024-26139/): OpenCTI Authenticated Privilege Escalation (high 8.3)
- [CVE-2024-45404](https://insights.sbomify.com/CVE-2024-45404/): OpenCTI's lack of Rate Limit lead to OTP brute forcing (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35212 and fix it if it is affected.

What it is: CVE-2026-35212 is a medium-severity cross-site scripting vulnerability in OpenCTI-Platform opencti, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-35212 in the wild and no public exploit code.

Affected packages and fixed versions:
- pycti (PyPI): affected all versions; fixed in 7.260227.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35212/ (Markdown: https://insights.sbomify.com/CVE-2026-35212/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35212
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35212
- OSV: https://osv.dev/vulnerability/CVE-2026-35212

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35212/
Summaries are generated and may contain mistakes; the official description above is the record.
