# CVE-2026-35213: Regular Expression Denial of Service (ReDoS) in @hapi/content HTTP header parsing

> Attackers can cause denial of service in applications using @hapi/content by sending crafted HTTP headers that trigger catastrophic regex backtracking.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 23 Jun 2026
- **Also known as:** CLEANSTART-2026-OG82185, MINI-5r6h-q74x-whh3, MINI-96w2-mm4g-jp88, MINI-cj6p-w63h-hfq6, MINI-grmg-7ghx-v2rp, MINI-h32j-r6pw-h8wf, MINI-j2jr-q7gg-5mrc, MINI-jfp7-3298-6w2f, MINI-m2gp-vq35-p748, MINI-m5q6-59wr-xhhm, MINI-mx29-v55f-q756, MINI-r569-4474-mm9q, ROOT-APP-NPM-CVE-2026-35213

## What is CVE-2026-35213?

CVE-2026-35213 is a high-severity denial of service vulnerability in hapijs content, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@hapi/content provided HTTP Content-* headers parsing. All versions of @hapi/content through 6.0.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via crafted HTTP header values. Three regular expressions used to parse Content-Type and Content-Disposition headers contain patterns susceptible to catastrophic backtracking. This vulnerability is fixed in 6.0.1.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-35213?

It affects 1 product.


Products: Content Project Content.

## How do I fix CVE-2026-35213?

Upgrade to a fixed version.

## Is CVE-2026-35213 being exploited?

There is no known exploitation of CVE-2026-35213 in the wild and no public exploit code.

## Other vulnerabilities in hapijs content

- [CVE-2017-16111](https://insights.sbomify.com/CVE-2017-16111/): Regular Expression Denial of Service in content (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35213 and fix it if it is affected.

What it is: CVE-2026-35213 is a high-severity denial of service vulnerability in hapijs content, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35213 in the wild and no public exploit code.

Affected product: hapijs content. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35213/ (Markdown: https://insights.sbomify.com/CVE-2026-35213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35213
- OSV: https://osv.dev/vulnerability/CVE-2026-35213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35213/
Summaries are generated and may contain mistakes; the official description above is the record.
