# CVE-2026-35219: Budibase: SSRF in Automation Steps - Webhook, Zapier, N8N, Slack, Discord Bypass IP Blacklist

> Authenticated users can bypass IP blacklists in automation steps to perform server-side requests, potentially accessing internal services or cloud metadata.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-5fpj-28rv-84r7

## What is CVE-2026-35219?

CVE-2026-35219 is a high-severity server-side request forgery vulnerability in budibase, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.41.3, automation steps in packages/server/src/automations/steps/outgoingWebhook.ts, packages/server/src/automations/steps/zapier.ts, packages/server/src/automations/steps/n8n.ts, packages/server/src/automations/steps/slack.ts, and packages/server/src/automations/steps/discord.ts use node-fetch on user-provided URLs without the BLACKLIST_IPS enforcement used by the REST integration, allowing an authenticated user to make server-side requests to cloud metadata and internal services. This issue is fixed in version 3.41.3.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-35219?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions | 3.41.3 |
| `@budibase/server` | npm | All versions | 3.41.3 |

## How do I fix CVE-2026-35219?

Upgrade @budibase/server to 3.41.3 or later.

## Is CVE-2026-35219 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35219 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35219 and fix it if it is affected.

What it is: CVE-2026-35219 is a high-severity server-side request forgery vulnerability in budibase, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35219 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions; fixed in 3.41.3
- @budibase/server (npm): affected all versions; fixed in 3.41.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35219/ (Markdown: https://insights.sbomify.com/CVE-2026-35219/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35219
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35219
- OSV: https://osv.dev/vulnerability/CVE-2026-35219

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35219/
Summaries are generated and may contain mistakes; the official description above is the record.
