# CVE-2026-35220: Joomla! Core - [20260505] - CSRF in user activation endpoint

> Attackers can force admin actions via CSRF in the user activation endpoint, requiring a patch to prevent unauthorized state changes.

- **Severity:** Medium 4.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 May 2026
- **Updated:** 27 May 2026
- **Also known as:** BIT-joomla-2026-35220, GHSA-h52w-g3vr-5c63

## What is CVE-2026-35220?

CVE-2026-35220 is a medium-severity vulnerability in Joomla Joomla\!, published on 26 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Lack of CSRF token validation lead to a CSRF attack vector in the admin activation endpoint of com_users.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-35220?

1 open source package ship an affected version, including joomla. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joomla` | Bitnami | From 6.0.0 | 6.1.1 |

Products: Joomla Joomla\!.

## How do I fix CVE-2026-35220?

Upgrade joomla to 6.1.1 or later.

## Is CVE-2026-35220 being exploited?

There is no known exploitation of CVE-2026-35220 in the wild and no public exploit code.

## Other vulnerabilities in Joomla Joomla\!

- [CVE-2016-10033](https://insights.sbomify.com/CVE-2016-10033/): PHPMailer Command Injection (critical 9.8, exploited in the wild)
- [CVE-2023-23752](https://insights.sbomify.com/CVE-2023-23752/): Joomla! Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-48902](https://insights.sbomify.com/CVE-2026-48902/): Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links (critical 9.8)
- [CVE-2025-25226](https://insights.sbomify.com/CVE-2025-25226/): [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package (critical 9.8)
- [CVE-2022-23795](https://insights.sbomify.com/CVE-2022-23795/): [20220303] - Core - User row are not bound to a authentication mechanism (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35220 and fix it if it is affected.

What it is: CVE-2026-35220 is a medium-severity vulnerability in Joomla Joomla\!, published on 26 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-35220 in the wild and no public exploit code.

Affected packages and fixed versions:
- joomla (Bitnami): affected from 6.0.0; fixed in 6.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35220/ (Markdown: https://insights.sbomify.com/CVE-2026-35220/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35220
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35220
- OSV: https://osv.dev/vulnerability/CVE-2026-35220

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35220/
Summaries are generated and may contain mistakes; the official description above is the record.
