{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-3529 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-3529 is a medium-severity cross-site scripting vulnerability in Drupal Google Analytics GA4, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-3529 and fix it if it is affected.\n\nWhat it is: CVE-2026-3529 is a medium-severity cross-site scripting vulnerability in Drupal Google Analytics GA4, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-3529 in the wild and no public exploit code.\n\nAffected product: Drupal Google Analytics GA4. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-3529/ (Markdown: https://insights.sbomify.com/CVE-2026-3529/index.md)","id":"CVE-2026-3529","markdown":"https://insights.sbomify.com/CVE-2026-3529/index.md","name":"CVE-2026-3529","record":{"aliases":["DRUPAL-CONTRIB-2026-024","GHSA-868m-2qw8-h5vx"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal GA4 module","requires_auth":"none","summary":"An attacker can inject malicious scripts into pages via the Drupal Google Analytics GA4 module, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"google_analytics_ga4","vendor":"sujanshrestha"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation (\"Cross-site Scripting\") vulnerability in Drupal Google Analytics GA4 allows Cross-Site Scripting (XSS).This issue affects Google Analytics GA4: from 0.0.0 before 1.1.14.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Google Analytics GA4 - Moderately critical - Cross-site Scripting - SA-CONTRIB-2026-024","id":"CVE-2026-3529","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Server-side request forgery in OpenID Connect / OAuth client","id":"CVE-2026-3530"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.1.14"],"introduced":["0"],"last_affected":[],"package":"drupal/ga4_google_analytics","purl":"pkg:composer/drupal/ga4_google_analytics?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2026-024"}],"prev":{"headline":"Calculation Fields - Moderately critical - Cross-site Scripting - SA-CONTRIB-2026-023","id":"CVE-2026-3528"},"products":["Google Analytics GA4"],"published":"2026-03-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-27","vendors":["Drupal"]},"summary":"An attacker can inject malicious scripts into pages via the Drupal Google Analytics GA4 module, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2026-3529/"}