# CVE-2026-35337: Apache Storm Client: RCE through Unsafe Deserialization via Kerberos TGT Credential Handling

> Authenticated attackers can achieve remote code execution in Nimbus and Worker JVMs by submitting malicious serialized objects via the Kerberos TGT credential field.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-jf89-3q6q-vcgr

## What is CVE-2026-35337?

CVE-2026-35337 is a high-severity unsafe deserialization vulnerability in Apache Storm Client, published on 13 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Deserialization of Untrusted Data vulnerability in Apache Storm.

Versions Affected:
before 2.8.6.

Description:
When processing topology credentials submitted via the Nimbus Thrift API, Storm deserializes the base64-encoded TGT blob using ObjectInputStream.readObject() without any class filtering or validation. An authenticated user with topology submission rights could supply a crafted serialized object in the "TGT" credential field, leading to remote code execution in both the Nimbus and Worker JVMs.

Mitigation:
2.x users should upgrade to 2.8.6.

Users who cannot upgrade immediately should monkey-patch an ObjectInputFilter allow-list to ClientAuthUtils.deserializeKerberosTicket() restricting deserialized classes to javax.security.auth.kerberos.KerberosTicket and its known dependencies. A guide on how to do this is available in the release notes of 2.8.6.

Credit: This issue was discovered by K.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-35337?

2 open source packages ship an affected version, including org.apache.storm:storm-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.storm:storm-client` | Maven | All versions | 2.8.6 |
| `org.apache.storm:storm-client` | Maven | All versions | 2.8.6 |

Products: Apache Storm.

## How do I fix CVE-2026-35337?

Upgrade org.apache.storm:storm-client to 2.8.6 or later.

## Is CVE-2026-35337 being exploited?

There is no known exploitation of CVE-2026-35337 in the wild and no public exploit code.

## Other vulnerabilities in Apache Storm Client

- [CVE-2021-38294](https://insights.sbomify.com/CVE-2021-38294/): Shell Command Injection Vulnerability in Nimbus Thrift Server (critical 9.8)
- [CVE-2021-40865](https://insights.sbomify.com/CVE-2021-40865/): Unsafe Pre-Authentication Deserialization In Workers (critical 9.8)
- [CVE-2018-11779](https://insights.sbomify.com/CVE-2018-11779/): Deserialization of Untrusted Data in Apache Storm (critical 9.8)
- [CVE-2015-3188](https://insights.sbomify.com/CVE-2015-3188/): Apache Storm remote code execution vulnerability (critical 9.8)
- [CVE-2018-1331](https://insights.sbomify.com/CVE-2018-1331/): Code execution in org.apache.storm:storm-core (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35337 and fix it if it is affected.

What it is: CVE-2026-35337 is a high-severity unsafe deserialization vulnerability in Apache Storm Client, published on 13 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35337 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.storm:storm-client (Maven): affected all versions; fixed in 2.8.6
- org.apache.storm:storm-client (Maven): affected all versions; fixed in 2.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35337/ (Markdown: https://insights.sbomify.com/CVE-2026-35337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35337
- OSV: https://osv.dev/vulnerability/CVE-2026-35337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35337/
Summaries are generated and may contain mistakes; the official description above is the record.
