# CVE-2026-35378: uutils coreutils expr Local Denial of Service via Eager Evaluation of Parenthesized Subexpressions

> A logic error in uutils coreutils expr causes premature script termination by failing to short-circuit logical operations, leading to denial of service.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-35378, GHSA-5pv5-xh52-hvrp, UBUNTU-CVE-2026-35378

## What is CVE-2026-35378?

CVE-2026-35378 is a low-severity denial of service vulnerability in Uutils coreutils, published on 22 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A logic error in the expr utility of uutils coreutils causes the program to evaluate parenthesized subexpressions during the parsing phase rather than at the execution phase. This implementation flaw prevents the utility from performing proper short-circuiting for logical OR (|) and AND (&) operations. As a result, arithmetic errors (such as division by zero) occurring within "dead" branches, branches that should be ignored due to short-circuiting, are raised as fatal errors. This divergence from GNU expr behavior can cause guarded expressions within shell scripts to fail with hard errors instead of returning expected boolean results, leading to premature script termination and breaking GNU-compatible shell control flow.

Weakness: CWE-768 (Incorrect Short Circuit Evaluation)

## Which versions are affected by CVE-2026-35378?

2 open source packages ship an affected version, including coreutils. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `coreutils` | crates.io | All versions | 0.8.0 |
| `coreutils` | crates.io | All versions | 0.8.0 |

Products: Uutils Coreutils.

## How do I fix CVE-2026-35378?

Upgrade coreutils to 0.8.0 or later.

## Is CVE-2026-35378 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35378 exists.

## Other vulnerabilities in Uutils coreutils

- [CVE-2026-35338](https://insights.sbomify.com/CVE-2026-35338/): uutils coreutils chmod Path Traversal Bypass of --preserve-root (high 7.3)
- [CVE-2026-35368](https://insights.sbomify.com/CVE-2026-35368/): uutils coreutils chroot Local Privilege Escalation and chroot Escape in via Name Service Switch (NSS) Injection (high 7.2)
- [CVE-2026-35341](https://insights.sbomify.com/CVE-2026-35341/): uutils coreutils mkfifo Unauthorized Permission Change on Existing Files (high 7.1)
- [CVE-2026-35352](https://insights.sbomify.com/CVE-2026-35352/): uutils coreutils mkfifo Privilege Escalation via TOCTOU Race Condition (high 7.0)
- [CVE-2026-35349](https://insights.sbomify.com/CVE-2026-35349/): uutils coreutils Path-Based Safety Bypass with --preserve-root (medium 6.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35378 and fix it if it is affected.

What it is: CVE-2026-35378 is a low-severity denial of service vulnerability in Uutils coreutils, published on 22 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35378 exists.

Affected packages and fixed versions:
- coreutils (crates.io): affected all versions; fixed in 0.8.0
- coreutils (crates.io): affected all versions; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35378/ (Markdown: https://insights.sbomify.com/CVE-2026-35378/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35378
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35378
- OSV: https://osv.dev/vulnerability/CVE-2026-35378

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35378/
Summaries are generated and may contain mistakes; the official description above is the record.
