# CVE-2026-35379: uutils coreutils tr Local Logic Error and Data Integrity Issue in Character Class Handling

> Logic error in tr utility incorrectly handles character classes, causing unintended data modification or loss in scripts relying on standard POSIX semantics.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-35379, GHSA-fhr3-xh3q-69w6, UBUNTU-CVE-2026-35379

## What is CVE-2026-35379?

CVE-2026-35379 is a low-severity vulnerability in Uutils coreutils, published on 22 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A logic error in the tr utility of uutils coreutils causes the program to incorrectly define the [:graph:] and [:print:] character classes. The implementation mistakenly includes the ASCII space character (0x20) in the [:graph:] class and excludes it from the [:print:] class, effectively reversing the standard behavior established by POSIX and GNU coreutils. This vulnerability leads to unintended data modification or loss when the utility is used in automated scripts or data-cleaning pipelines that rely on standard character class semantics. For example, a command executed to delete all graphical characters while intending to preserve whitespace will incorrectly delete all ASCII spaces, potentially resulting in data corruption or logic failures in downstream processing.

Weakness: CWE-684 (Incorrect Provision of Specified Functionality)

## Which versions are affected by CVE-2026-35379?

2 open source packages ship an affected version, including coreutils. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `coreutils` | crates.io | All versions | 0.8.0 |
| `coreutils` | crates.io | All versions | 0.8.0 |

Products: Uutils Coreutils.

## How do I fix CVE-2026-35379?

Upgrade coreutils to 0.8.0 or later.

## Is CVE-2026-35379 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35379 exists.

## Other vulnerabilities in Uutils coreutils

- [CVE-2026-35338](https://insights.sbomify.com/CVE-2026-35338/): uutils coreutils chmod Path Traversal Bypass of --preserve-root (high 7.3)
- [CVE-2026-35368](https://insights.sbomify.com/CVE-2026-35368/): uutils coreutils chroot Local Privilege Escalation and chroot Escape in via Name Service Switch (NSS) Injection (high 7.2)
- [CVE-2026-35341](https://insights.sbomify.com/CVE-2026-35341/): uutils coreutils mkfifo Unauthorized Permission Change on Existing Files (high 7.1)
- [CVE-2026-35352](https://insights.sbomify.com/CVE-2026-35352/): uutils coreutils mkfifo Privilege Escalation via TOCTOU Race Condition (high 7.0)
- [CVE-2026-35349](https://insights.sbomify.com/CVE-2026-35349/): uutils coreutils Path-Based Safety Bypass with --preserve-root (medium 6.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35379 and fix it if it is affected.

What it is: CVE-2026-35379 is a low-severity vulnerability in Uutils coreutils, published on 22 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35379 exists.

Affected packages and fixed versions:
- coreutils (crates.io): affected all versions; fixed in 0.8.0
- coreutils (crates.io): affected all versions; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35379/ (Markdown: https://insights.sbomify.com/CVE-2026-35379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35379
- OSV: https://osv.dev/vulnerability/CVE-2026-35379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35379/
Summaries are generated and may contain mistakes; the official description above is the record.
