# CVE-2026-35397: jupyter-server path traversal allows access to sibling directories sharing root_dir name prefix

> Authenticated users can escape the configured root directory to read, write, and delete files in sibling directories sharing a name prefix.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 28 Aug 2026
- **Also known as:** CLEANSTART-2026-BF97060, CLEANSTART-2026-UA81846, DEBIAN-CVE-2026-35397, GHSA-5789-5fc7-67v3, PYSEC-2026-68, UBUNTU-CVE-2026-35397

## What is CVE-2026-35397?

CVE-2026-35397 is a high-severity path traversal vulnerability in jupyter-server jupyter_server, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jupyter Server is the backend for Jupyter web applications. In versions 2.17.0 and earlier, a path traversal vulnerability in the REST API allows an authenticated user to escape the configured root_dir and access sibling directories whose names begin with the same prefix as the root_dir. For example, with a root_dir named "test", the API permits access to a sibling directory named "testtest" through a crafted request to the /api/contents endpoint using encoded path components. An attacker can read, write, and delete files in affected sibling directories. Multi-tenant deployments using predictable naming schemes are particularly at risk, as a user with a directory named "user1" could access directories for user10 through user19 and beyond. A user who can choose a single-character folder name could gain access to a significant number of sibling directories. 

Version 2.18.0 contains a fix. As a workaround, ensure folder names do not share a common prefix with any sibling directory.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-35397?

3 open source packages ship an affected version, including jupyter-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-server` | PyPI | All versions | 2.18.0 |
| `jupyter-server` | PyPI | All versions | 2.18.0 |
| `jupyter-server` | PyPI | All versions | 2.18.0 |

Products: Jupyter Jupyter Server.

## How do I fix CVE-2026-35397?

Upgrade jupyter-server to 2.18.0 or later.

## Is CVE-2026-35397 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35397 exists.

Public exploit code:

- https://github.com/HiteshGorana/susvibes-jupyter-server-cve-2026-35397 (github_poc): https://github.com/HiteshGorana/susvibes-jupyter-server-cve-2026-35397

## Other vulnerabilities in jupyter-server jupyter_server

- [CVE-2026-44727](https://insights.sbomify.com/CVE-2026-44727/): Jupyter Server: Stored XSS in `NbconvertFileHandler` / `NbconvertPostHandler` via missing `sandbox` CSP (critical 9.3)
- [CVE-2026-40110](https://insights.sbomify.com/CVE-2026-40110/): jupyter-server CORS origin validation bypass via unanchored regex in allow_origin_pat (high 7.6)
- [CVE-2026-40934](https://insights.sbomify.com/CVE-2026-40934/): jupyter-server authentication cookies remain valid after password reset due to static cookie secret (high 7.6)
- [CVE-2024-35178](https://insights.sbomify.com/CVE-2024-35178/): Jupyter server on Windows discloses Windows user password hash (high 7.5)
- [CVE-2022-24757](https://insights.sbomify.com/CVE-2022-24757/): Sensitive Auth & Cookie data stored in Jupyter server logs (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35397 and fix it if it is affected.

What it is: CVE-2026-35397 is a high-severity path traversal vulnerability in jupyter-server jupyter_server, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35397 exists.

Affected packages and fixed versions:
- jupyter-server (PyPI): affected all versions; fixed in 2.18.0
- jupyter-server (PyPI): affected all versions; fixed in 2.18.0
- jupyter-server (PyPI): affected all versions; fixed in 2.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35397/ (Markdown: https://insights.sbomify.com/CVE-2026-35397/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35397
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35397
- OSV: https://osv.dev/vulnerability/CVE-2026-35397

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35397/
Summaries are generated and may contain mistakes; the official description above is the record.
