# CVE-2026-35441: Directus Affected by GraphQL Alias Amplification Denial-of-Service Due to Missing Query Cost/Complexity Limits

> Authenticated users can cause denial of service in Directus by exploiting GraphQL aliasing to exhaust server resources due to missing query cost limits.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** GHSA-ph52-67fq-75wj

## What is CVE-2026-35441?

CVE-2026-35441 is a medium-severity denial of service vulnerability in Monospace Directus, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Directus is a real-time API and App dashboard for managing SQL database content. Prior to 11.17.0, Directus' GraphQL endpoints (/graphql and /graphql/system) did not deduplicate resolver invocations within a single request. An authenticated user could exploit GraphQL aliasing to repeat an expensive relational query many times in a single request, forcing the server to execute a large number of independent complex database queries concurrently, multiplying database load linearly with the number of aliases. The existing token limit on GraphQL queries still permitted enough aliases for significant resource exhaustion, while the relational depth limit applied per alias without reducing the total number executed. Rate limiting is disabled by default, meaning no built-in throttle prevented this from causing CPU, memory, and I/O exhaustion that could degrade or crash the service. Any authenticated user, including those with minimal read-only permissions, could trigger this condition. This vulnerability is fixed in 11.17.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-35441?

2 open source packages ship an affected version, including directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `directus` | npm | All versions | 11.17.0 |
| `directus` | npm | All versions | 11.17.0 |

Products: Monospace Directus.

## How do I fix CVE-2026-35441?

Upgrade directus to 11.17.0 or later.

## Is CVE-2026-35441 being exploited?

There is no known exploitation of CVE-2026-35441 in the wild and no public exploit code.

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35441 and fix it if it is affected.

What it is: CVE-2026-35441 is a medium-severity denial of service vulnerability in Monospace Directus, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35441 in the wild and no public exploit code.

Affected packages and fixed versions:
- directus (npm): affected all versions; fixed in 11.17.0
- directus (npm): affected all versions; fixed in 11.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35441/ (Markdown: https://insights.sbomify.com/CVE-2026-35441/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35441
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35441
- OSV: https://osv.dev/vulnerability/CVE-2026-35441

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35441/
Summaries are generated and may contain mistakes; the official description above is the record.
