# CVE-2026-35445: Winter: Authenticated backend users can bypass Users controller permission checks


- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** GHSA-j5jq-cr68-v2xx

## What is CVE-2026-35445?

CVE-2026-35445 is a high-severity vulnerability in wintercms winter, published on 26 Aug 2026. 

### Official description

Winter CMS is a content management system built on the Laravel PHP framework. In versions prior to 1.2.13, the backend did not validate the handler name submitted through the form postback _handler POST field, allowing an authenticated backend user to invoke arbitrary controller methods, including protected, private, and action-prefixed ones. While AJAX requests validate that handler names match the on[A-Z][\w+]* pattern, the postback path passed the submitted _handler value straight to the handler dispatcher with no such check, so any controller that exposes a public action or conditionally relaxes its $requiredPermissions check could be reached, bypassing the roles and permissions system. The built-in Users controller was affected because it set $requiredPermissions to null for the myaccount action, letting any authenticated backend user invoke user-management methods such as update_onDelete and update_onManualPasswordReset without holding the backend.manage_users permission. This issue is fixed in version 1.2.13.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-35445?

2 open source packages ship an affected version, including winter/wn-backend-module.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `winter/wn-backend-module` | Packagist | All versions | 1.2.13 |
| `winter/wn-backend-module` | Packagist | All versions | 1.2.13 |

## How do I fix CVE-2026-35445?

Upgrade winter/wn-backend-module to 1.2.13 or later.

## Is CVE-2026-35445 being exploited?

There is no known exploitation of CVE-2026-35445 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35445 and fix it if it is affected.

What it is: CVE-2026-35445 is a high-severity vulnerability in wintercms winter, published on 26 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-35445 in the wild and no public exploit code.

Affected packages and fixed versions:
- winter/wn-backend-module (Packagist): affected all versions; fixed in 1.2.13
- winter/wn-backend-module (Packagist): affected all versions; fixed in 1.2.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35445/ (Markdown: https://insights.sbomify.com/CVE-2026-35445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35445
- OSV: https://osv.dev/vulnerability/CVE-2026-35445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35445/
Summaries are generated and may contain mistakes; the official description above is the record.
