# CVE-2026-35453: PhpSpreadsheet XSS via number format text substitution in HTML Writer

> Attackers can inject arbitrary HTML and JavaScript into spreadsheet outputs via the HTML Writer, potentially leading to code execution in consuming applications.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 6 May 2026
- **Also known as:** GHSA-6wpp-88cp-7q68

## What is CVE-2026-35453?

CVE-2026-35453 is a medium-severity cross-site scripting vulnerability in PHPOffice PhpSpreadsheet, published on 5 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

PhpSpreadsheet is a library for reading and writing spreadsheet files. In versions 1.30.3 and earlier, 2.0.0 through 2.1.15, 2.2.0 through 2.4.4, 3.3.0 through 3.10.4, and 4.0.0 through 5.6.0, the HTML Writer skips htmlspecialchars() output escaping when a cell uses a custom number format containing the @ text placeholder with additional literal text (e.g., @ "items"). The escaping is only applied when the formatted output strictly equals the original cell value. When the format code contains @ with quoted literal text, the formatter substitutes the raw cell value into the format string and returns early without invoking the escaping callback. An attacker who can control cell content in a spreadsheet processed by the HTML Writer can inject arbitrary HTML and JavaScript into the generated output. This issue has been fixed in versions 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-35453?

10 open source packages ship an affected version, including phpoffice/phpspreadsheet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.4 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.4 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.16 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.16 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.5 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.5 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.10.5 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.10.5 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.7.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.7.0 |

Products: Phpoffice Phpspreadsheet.

## How do I fix CVE-2026-35453?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.30.4, 2.1.16, 2.4.5 or 3.10.5.

## Is CVE-2026-35453 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35453 exists.

## Other vulnerabilities in PHPOffice PhpSpreadsheet

- [CVE-2026-34084](https://insights.sbomify.com/CVE-2026-34084/): PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load (critical 9.2)
- [CVE-2024-45048](https://insights.sbomify.com/CVE-2024-45048/): XML External Entity Reference (XXE) in PHPSpreadsheet (high 8.8)
- [CVE-2019-12331](https://insights.sbomify.com/CVE-2019-12331/): XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue (high 8.8)
- [CVE-2018-19277](https://insights.sbomify.com/CVE-2018-19277/): XXE in PHPSpreadsheet due to encoding issue (high 8.8)
- [CVE-2024-56365](https://insights.sbomify.com/CVE-2024-56365/): PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35453 and fix it if it is affected.

What it is: CVE-2026-35453 is a medium-severity cross-site scripting vulnerability in PHPOffice PhpSpreadsheet, published on 5 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35453 exists.

Affected packages and fixed versions:
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.4
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.4
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.16
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.16
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.5
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.5
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.5
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.5
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.7.0
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35453/ (Markdown: https://insights.sbomify.com/CVE-2026-35453/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35453
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35453
- OSV: https://osv.dev/vulnerability/CVE-2026-35453

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35453/
Summaries are generated and may contain mistakes; the official description above is the record.
