# CVE-2026-35463: pyLoad has Improper Neutralization of Special Elements used in an OS Command

> A non-admin user can achieve remote code execution by modifying the AntiVirus plugin's executable path due to missing admin-only restrictions on plugin configurations.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-w48f-wwwf-f5fr, PYSEC-2026-2267

## What is CVE-2026-35463?

CVE-2026-35463 is a high-severity command injection vulnerability in pyload, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pyLoad is a free and open-source download manager written in Python. In 0.5.0b3.dev96 and earlier, the ADMIN_ONLY_OPTIONS protection mechanism restricts security-critical configuration values (reconnect scripts, SSL certs, proxy credentials) to admin-only access. However, this protection is only applied to core config options, not to plugin config options. The AntiVirus plugin stores an executable path (avfile) in its config, which is passed directly to subprocess.Popen(). A non-admin user with SETTINGS permission can change this path to achieve remote code execution.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-35463?

3 open source packages ship an affected version, including pyload-ng. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyload-ng` | PyPI | All versions to 0.5.0b3.dev96 | None |
| `pyload-ng` | PyPI | All versions to 0.5.0b3.dev96 | None |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev97 |

Products: Pyload-Ng Project Pyload-Ng.

## How do I fix CVE-2026-35463?

Upgrade pyload-ng to 0.5.0b3.dev97 or later.

## Is CVE-2026-35463 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35463 exists.

## Other vulnerabilities in pyload

- [CVE-2025-54802](https://insights.sbomify.com/CVE-2025-54802/): pyLoad CNL Blueprint is vulnerable to Path Traversal through `dlc_path` leading to Remote Code Execution (RCE) (critical 9.8)
- [CVE-2024-22416](https://insights.sbomify.com/CVE-2024-22416/): Cross-Site Request Forgery on any API call in pyLoad may lead to admin privilege escalation (critical 9.7)
- [CVE-2023-0488](https://insights.sbomify.com/CVE-2023-0488/): Cross-site Scripting (XSS) - Stored in pyload/pyload (critical 9.6)
- [CVE-2026-35459](https://insights.sbomify.com/CVE-2026-35459/): pyLoad has SSRF fix bypass via HTTP redirect (critical 9.3)
- [CVE-2026-33511](https://insights.sbomify.com/CVE-2026-33511/): pyload-ng: Authentication Bypass via Host Header Injection in ClickNLoad (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35463 and fix it if it is affected.

What it is: CVE-2026-35463 is a high-severity command injection vulnerability in pyload, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35463 exists.

Affected packages and fixed versions:
- pyload-ng (PyPI): affected all versions up to 0.5.0b3.dev96; no fix listed
- pyload-ng (PyPI): affected all versions up to 0.5.0b3.dev96; no fix listed
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev97

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35463/ (Markdown: https://insights.sbomify.com/CVE-2026-35463/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35463
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35463
- OSV: https://osv.dev/vulnerability/CVE-2026-35463

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35463/
Summaries are generated and may contain mistakes; the official description above is the record.
