# CVE-2026-35470: OpenSTAManager has a SQL Injection via righe Parameter in confronta_righe Modals

> An authenticated attacker can inject SQL via the righe parameter to extract sensitive database information from OpenSTAManager.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** GHSA-mmm5-3g4x-qw39

## What is CVE-2026-35470?

CVE-2026-35470 is a high-severity SQL injection vulnerability in devcode-it openstamanager, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenSTAManager is an open source management software for technical assistance and invoicing. Prior to 2.10.2, confronta_righe.php files across different modules in OpenSTAManager contain an SQL Injection vulnerability. The righe parameter received via $_GET['righe'] is directly concatenated into an SQL query without any sanitization, parameterization or validation. An authenticated attacker can inject arbitrary SQL statements to extract sensitive data from the database, including user credentials, customer information, invoice data and any other stored data. This vulnerability is fixed in 2.10.2.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-35470?

2 open source packages ship an affected version, including devcode-it/openstamanager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devcode-it/openstamanager` | Packagist | All versions | 2.10.2 |
| `devcode-it/openstamanager` | Packagist | All versions | 2.10.2 |

Products: Devcode Openstamanager.

## How do I fix CVE-2026-35470?

Upgrade devcode-it/openstamanager to 2.10.2 or later.

## Is CVE-2026-35470 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35470 exists.

## Other vulnerabilities in devcode-it openstamanager

- [CVE-2026-27012](https://insights.sbomify.com/CVE-2026-27012/): Unauthenticated privilege escalation in OpenSTAManager via modules/utenti/actions.php (critical 9.8)
- [CVE-2025-69212](https://insights.sbomify.com/CVE-2025-69212/): OpenSTAManager has an OS Command Injection in P7M File Processing (critical 9.4)
- [CVE-2026-28805](https://insights.sbomify.com/CVE-2026-28805/): OpenSTAManager: Time-Based Blind SQL Injection via `options[stato]` Parameter (high 8.8)
- [CVE-2026-35168](https://insights.sbomify.com/CVE-2026-35168/): OpenSTAManager: SQL Injection via Aggiornamenti Module (high 8.8)
- [CVE-2025-69214](https://insights.sbomify.com/CVE-2025-69214/): OpenSTAManager has a SQL Injection in ajax_select.php (componenti endpoint) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35470 and fix it if it is affected.

What it is: CVE-2026-35470 is a high-severity SQL injection vulnerability in devcode-it openstamanager, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35470 exists.

Affected packages and fixed versions:
- devcode-it/openstamanager (Packagist): affected all versions; fixed in 2.10.2
- devcode-it/openstamanager (Packagist): affected all versions; fixed in 2.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35470/ (Markdown: https://insights.sbomify.com/CVE-2026-35470/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35470
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35470
- OSV: https://osv.dev/vulnerability/CVE-2026-35470

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35470/
Summaries are generated and may contain mistakes; the official description above is the record.
