# CVE-2026-35490: changedetection.io has an Authentication Bypass via Decorator Ordering

> Attackers can bypass authentication on specific routes due to incorrect decorator ordering in changedetection.io, allowing unauthorized access to protected features.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** GHSA-jmrh-xmgh-x9j4, PYSEC-2026-28

## What is CVE-2026-35490?

CVE-2026-35490 is a critical authentication bypass vulnerability in dgtlmoon changedetection.io, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

changedetection.io is a free open source web page change detection tool. Prior to 0.54.8, the @login_optionally_required decorator is placed before (outer to) @blueprint.route() instead of after it. In Flask, @route() must be the outermost decorator because it registers the function it receives. When the order is reversed, @route() registers the original undecorated function, and the auth wrapper is never in the call chain. This silently disables authentication on these routes. This vulnerability is fixed in 0.54.8.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-35490?

3 open source packages ship an affected version, including changedetection.io and changedetection-io. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `changedetection.io` | PyPI | All versions | 0.54.8 |
| `changedetection-io` | PyPI | All versions | 0.54.8 |
| `changedetection-io` | PyPI | All versions | 0.54.8 |

Products: Webtechnologies Changedetection.

## How do I fix CVE-2026-35490?

Upgrade changedetection.io to 0.54.8 or later.

## Is CVE-2026-35490 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35490 exists.

## Other vulnerabilities in dgtlmoon changedetection.io

- [CVE-2026-29039](https://insights.sbomify.com/CVE-2026-29039/): changedetection.io: XPath - Arbitrary File Read via unparsed-text() (high 8.8)
- [CVE-2026-29065](https://insights.sbomify.com/CVE-2026-29065/): changedetection.io: Zip Slip vulnerability in the backup restore functionality (high 8.8)
- [CVE-2026-27696](https://insights.sbomify.com/CVE-2026-27696/): changedetection.io Vulnerable to Server-Side Request Forgery (SSRF) via Watch URLs (high 8.6)
- [CVE-2026-33981](https://insights.sbomify.com/CVE-2026-33981/): Changedetection.io Discloses Environment Variables via jq env Builtin in Include Filters (high 8.3)
- [CVE-2026-41895](https://insights.sbomify.com/CVE-2026-41895/): changedetection.io: XXE vulnerability in the changedetection.io project (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35490 and fix it if it is affected.

What it is: CVE-2026-35490 is a critical authentication bypass vulnerability in dgtlmoon changedetection.io, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35490 exists.

Affected packages and fixed versions:
- changedetection.io (PyPI): affected all versions; fixed in 0.54.8
- changedetection-io (PyPI): affected all versions; fixed in 0.54.8
- changedetection-io (PyPI): affected all versions; fixed in 0.54.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35490/ (Markdown: https://insights.sbomify.com/CVE-2026-35490/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35490
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35490
- OSV: https://osv.dev/vulnerability/CVE-2026-35490

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35490/
Summaries are generated and may contain mistakes; the official description above is the record.
