# CVE-2026-35523: Authentication bypass in strawberry-graphql via legacy graphql-ws WebSocket subprotocol

> Attackers can bypass authentication on WebSocket subscription endpoints by using the legacy graphql-ws subprotocol without completing the handshake.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** GHSA-vpwc-v33q-mq89, PYSEC-2026-133, ROOT-APP-PYPI-CVE-2026-35523

## What is CVE-2026-35523?

CVE-2026-35523 is a high-severity authentication bypass vulnerability in strawberry-graphql strawberry, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Strawberry GraphQL is a library for creating GraphQL APIs. Strawberry up until version 0.312.3 is vulnerable to an authentication bypass on WebSocket subscription endpoints. The legacy graphql-ws subprotocol handler does not verify that a connection_init handshake has been completed before processing start (subscription) messages. This allows a remote attacker to skip the on_ws_connect authentication hook entirely by connecting with the graphql-ws subprotocol and sending a start message directly, without ever sending connection_init.  This vulnerability is fixed in 0.312.3.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-35523?

3 open source packages ship an affected version, including strawberry-graphql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `strawberry-graphql` | PyPI | All versions | 0.312.3 |
| `strawberry-graphql` | PyPI | All versions | 0.312.3 |
| `strawberry-graphql` | PyPI | All versions | 0.312.3 |

Products: Strawberry Strawberry Graphql.

## How do I fix CVE-2026-35523?

Upgrade strawberry-graphql to 0.312.3 or later.

## Is CVE-2026-35523 being exploited?

There is no known exploitation of CVE-2026-35523 in the wild and no public exploit code.

## Other vulnerabilities in strawberry-graphql strawberry

- [CVE-2026-35526](https://insights.sbomify.com/CVE-2026-35526/): Strawberry GraphQL affected by a Denial of Service via unbounded WebSocket subscriptions (high 7.5)
- [CVE-2026-47706](https://insights.sbomify.com/CVE-2026-47706/): Strawberry GraphQL has a Circular Fragment Reference DOS (medium 5.3)
- [CVE-2026-47707](https://insights.sbomify.com/CVE-2026-47707/): Strawberry GraphQL's Bypass of MaxAliasesLimiter via Fragment Spreads leading to GraphQL Alias Amplification (medium 5.3)
- [CVE-2026-45739](https://insights.sbomify.com/CVE-2026-45739/): Strawberry GraphQL: Default GraphiQL may expose HTTP headers in URLs (low 3.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35523 and fix it if it is affected.

What it is: CVE-2026-35523 is a high-severity authentication bypass vulnerability in strawberry-graphql strawberry, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35523 in the wild and no public exploit code.

Affected packages and fixed versions:
- strawberry-graphql (PyPI): affected all versions; fixed in 0.312.3
- strawberry-graphql (PyPI): affected all versions; fixed in 0.312.3
- strawberry-graphql (PyPI): affected all versions; fixed in 0.312.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35523/ (Markdown: https://insights.sbomify.com/CVE-2026-35523/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35523
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35523
- OSV: https://osv.dev/vulnerability/CVE-2026-35523

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35523/
Summaries are generated and may contain mistakes; the official description above is the record.
