# CVE-2026-35527: Incus blind SSRF via image import preflight HEAD request

> Authenticated users can trigger blind SSRF via image import, probing internal services and leaking host metadata before policy checks apply.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 6 May 2026
- **Also known as:** DEBIAN-CVE-2026-35527, GHSA-8gw4-p4wq-4hcv, GO-2026-5254, UBUNTU-CVE-2026-35527

## What is CVE-2026-35527?

CVE-2026-35527 is a medium-severity server-side request forgery vulnerability in lxc incus, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incus is an open source container and virtual machine manager. In versions prior to 7.0.0, the image import flow issues an outbound HEAD request to a user-supplied URL before validating the request against project restrictions such as restricted.images.servers. The imgPostURLInfo function constructs and sends a HEAD request directly from the attacker-supplied source URL to resolve image metadata, and this network interaction occurs before the flow reaches the point where the import would be rejected by policy. Although the actual image download is blocked by the project restriction, an authenticated user can coerce the daemon into making blind HEAD requests to arbitrary destinations.

These requests include server metadata in custom headers (Incus-Server-Architectures, Incus-Server-Version), which discloses information about the host environment to the attacker-controlled endpoint. This blind SSRF primitive can be used to probe internal services, unroutable address space, or cloud metadata endpoints reachable from the host.

This vulnerability pattern is similar to CVE-2026-24767. This issue has been fixed in version 7.0.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-35527?

5 open source packages ship an affected version, including github.com/lxc/incus/v6/cmd/incusd, github.com/lxc/incus and github.com/lxc/incus/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions | 7.0.0 |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions | 7.0.0 |
| `github.com/lxc/incus` | Go | All versions | None |
| `github.com/lxc/incus/v6` | Go | All versions | None |
| `github.com/lxc/incus/v7` | Go | All versions | 7.0.0 |

Products: Linuxcontainers Incus.

## How do I fix CVE-2026-35527?

Upgrade github.com/lxc/incus/v6/cmd/incusd to 7.0.0 or later.

## Is CVE-2026-35527 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35527 exists.

## Other vulnerabilities in lxc incus

- [CVE-2026-33897](https://insights.sbomify.com/CVE-2026-33897/): Incus vulnerable to arbitrary file read and write through pongo templates (critical 10.0)
- [CVE-2026-33945](https://insights.sbomify.com/CVE-2026-33945/): Abitrary file write through systemd-creds option (critical 10.0)
- [CVE-2026-33898](https://insights.sbomify.com/CVE-2026-33898/): Local Incus UI web server vulnerable to nuthentication bypass (high 8.8)
- [CVE-2026-23953](https://insights.sbomify.com/CVE-2026-23953/): Incus container environment configuration newline injection (high 8.7)
- [CVE-2026-23954](https://insights.sbomify.com/CVE-2026-23954/): Incus container image templating arbitrary host file read and write (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35527 and fix it if it is affected.

What it is: CVE-2026-35527 is a medium-severity server-side request forgery vulnerability in lxc incus, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35527 exists.

Affected packages and fixed versions:
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions; fixed in 7.0.0
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions; fixed in 7.0.0
- github.com/lxc/incus (Go): affected all versions; no fix listed
- github.com/lxc/incus/v6 (Go): affected all versions; no fix listed
- github.com/lxc/incus/v7 (Go): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35527/ (Markdown: https://insights.sbomify.com/CVE-2026-35527/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35527
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35527
- OSV: https://osv.dev/vulnerability/CVE-2026-35527

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35527/
Summaries are generated and may contain mistakes; the official description above is the record.
