# CVE-2026-35536: Tornado has incomplete validation of cookie attributes

> Attackers can inject crafted characters into cookie attributes in Tornado, potentially bypassing security controls.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** BELL-CVE-2026-35536, CLEANSTART-2026-GY87209, CLEANSTART-2026-MP46528, CLEANSTART-2026-UK29776, DEBIAN-CVE-2026-35536, ECHO-2021-f695-d29d, ECHO-b644-e810-f4a8, GHSA-78cv-mqj4-43f7, GHSA-fqwm-6jpj-5wxc, MINI-6336-36xr-j48w, MINI-6hhg-95c4-rj6f, MINI-7ww7-6x72-cv94, MINI-jx47-wh5p-2wgp, MINI-m4w2-75xg-7r52, MINI-mcg4-gwf9-w4v3, MINI-mxfc-w22f-6v6h, MINI-rh7h-2gg8-h9fr, PYSEC-2026-2287, ROOT-APP-PYPI-CVE-2026-35536, ROOT-APP-PYPI-GHSA-78cv-mqj4-43f7, UBUNTU-CVE-2026-35536

## What is CVE-2026-35536?

CVE-2026-35536 is a high-severity vulnerability in tornadoweb Tornado, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Tornado before 6.5.5, cookie attribute injection could occur because the domain, path, and samesite arguments to .RequestHandler.set_cookie were not checked for crafted characters.

Weakness: CWE-159 (Improper Handling of Invalid Use of Special Elements)

## Which versions are affected by CVE-2026-35536?

5 open source packages ship an affected version, including tornado. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tornado` | PyPI | All versions | 6.5.5 |
| `tornado` | PyPI | All versions | 6.5.5 |
| `tornado` | PyPI | All versions | 6.5.5 |
| `tornado` | PyPI | All versions | 6.5.5 |
| `tornado` | PyPI | All versions | 6.5.5 |

Products: Tornadoweb Tornado.

## How do I fix CVE-2026-35536?

Upgrade tornado to 6.5.5 or later.

## Is CVE-2026-35536 being exploited?

There is no known exploitation of CVE-2026-35536 in the wild and no public exploit code.

## Other vulnerabilities in tornadoweb Tornado

- [CVE-2026-31958](https://insights.sbomify.com/CVE-2026-31958/): Tornado has a DoS due to too many multipart parts (high 8.7)
- [CVE-2025-67725](https://insights.sbomify.com/CVE-2025-67725/): Tornado is Vulnerable to Quadratic DoS via Repeated Header Coalescing (high 7.5)
- [CVE-2025-67726](https://insights.sbomify.com/CVE-2025-67726/): Tornado is Vulnerable to Quadratic DoS via Crafted Multipart Parameters (high 7.5)
- [CVE-2024-52804](https://insights.sbomify.com/CVE-2024-52804/): Tornado has HTTP cookie parsing DoS vulnerability (high 7.5)
- [CVE-2014-9720](https://insights.sbomify.com/CVE-2014-9720/): Tornado XSRF cookie allows side-channel attack against TLS (BREACH attack) (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35536 and fix it if it is affected.

What it is: CVE-2026-35536 is a high-severity vulnerability in tornadoweb Tornado, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35536 in the wild and no public exploit code.

Affected packages and fixed versions:
- tornado (PyPI): affected all versions; fixed in 6.5.5
- tornado (PyPI): affected all versions; fixed in 6.5.5
- tornado (PyPI): affected all versions; fixed in 6.5.5
- tornado (PyPI): affected all versions; fixed in 6.5.5
- tornado (PyPI): affected all versions; fixed in 6.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35536/ (Markdown: https://insights.sbomify.com/CVE-2026-35536/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35536
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35536
- OSV: https://osv.dev/vulnerability/CVE-2026-35536

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35536/
Summaries are generated and may contain mistakes; the official description above is the record.
