{"answers":{"affected":"2 open source packages ship an affected version, including roundcube/roundcubemail. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-35541 in the wild and no public exploit code.","fix":"Upgrade roundcube/roundcubemail to 1.7-rc5 or later.","what":"CVE-2026-35541 is a medium-severity authentication bypass vulnerability in Roundcube Webmail, published on 3 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-35541 and fix it if it is affected.\n\nWhat it is: CVE-2026-35541 is a medium-severity authentication bypass vulnerability in Roundcube Webmail, published on 3 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-35541 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- roundcube/roundcubemail (Packagist): affected from 1.7-beta; fixed in 1.7-rc5\n- roundcube/roundcubemail (Packagist): affected from 1.7-beta; fixed in 1.7-rc5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-35541/ (Markdown: https://insights.sbomify.com/CVE-2026-35541/index.md)","id":"CVE-2026-35541","markdown":"https://insights.sbomify.com/CVE-2026-35541/index.md","name":"CVE-2026-35541","record":{"aliases":["DEBIAN-CVE-2026-35541","GHSA-46pv-mj2g-93gh","UBUNTU-CVE-2026-35541"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Roundcube Webmail","requires_auth":"low_privilege","summary":"Attackers can change user passwords without knowing the old password due to type confusion in the password plugin, leading to account takeover.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"webmail","vendor":"roundcube"}],"cvss":{"score":4.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"}],"description":"An issue was discovered in Roundcube Webmail before 1.5.14 and 1.6.14. Incorrect password comparison in the password plugin could lead to type confusion that allows a password change without knowing the old password.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Roundcube Webmail: Incorrect password comparison in the password plugin","id":"CVE-2026-35541","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"roundcube:webmail","products":["roundcube:webmail"],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":7,"next":{"headline":"Roundcube: Bypass of remote image blocking via crafted BODY background attribute","id":"CVE-2026-35542"},"packages":[{"ecosystem":"Packagist","fixed":["1.7-rc5"],"introduced":["1.7-beta"],"last_affected":[],"package":"roundcube/roundcubemail","purl":null,"source":"GHSA-46pv-mj2g-93gh"},{"ecosystem":"Packagist","fixed":["1.7-rc5"],"introduced":["1.7-beta"],"last_affected":[],"package":"roundcube/roundcubemail","purl":"pkg:composer/roundcube/roundcubemail","source":"GHSA-46pv-mj2g-93gh"}],"prev":{"headline":"Roundcube Webmail: Insufficient CSS sanitization in HTML e-mail messages","id":"CVE-2026-35540"},"products":["Webmail"],"published":"2026-04-03","related":[{"cvss_score":9.3,"headline":"RoundCube Webmail Cross-Site Scripting","id":"CVE-2024-42009","kev_date_added":"2025-06-09","published":"2024-08-05"},{"cvss_score":7.2,"headline":"RoundCube Webmail Cross-site Scripting","id":"CVE-2025-68461","kev_date_added":"2026-02-20","published":"2025-12-18"},{"cvss_score":10,"headline":"PHPMailer susceptible to arbitrary code execution","id":"CVE-2008-5619","kev_date_added":null,"published":"2008-12-17"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2024-37385","kev_date_added":null,"published":"2024-06-07"},{"cvss_score":9.3,"headline":"Cross-site scripting in n/a","id":"CVE-2024-42008","kev_date_added":null,"published":"2024-08-05"},{"cvss_score":8.8,"headline":"Command injection in Webmail","id":"CVE-2026-74997","kev_date_added":null,"published":"2026-08-17"},{"cvss_score":8.8,"headline":"Privilege escalation in n/a","id":"CVE-2017-8114","kev_date_added":null,"published":"2017-04-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-03","vendors":["Roundcube"]},"summary":"Attackers can change user passwords without knowing the old password due to type confusion in the password plugin, leading to account takeover.","url":"https://insights.sbomify.com/CVE-2026-35541/"}