# CVE-2026-35554: Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition

> A race condition in the Kafka producer client can cause messages to be silently delivered to incorrect topics, exposing sensitive data and corrupting downstream processing.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** CLEANSTART-2026-BR61448, CLEANSTART-2026-HV53222, CLEANSTART-2026-KI11233, CLEANSTART-2026-VH87962, CLEANSTART-2026-WO81380, ECHO-9d81-4fd7-174c, GHSA-5qcv-4rpc-jp93, MINI-226q-vv8f-vjqv, MINI-29m2-h68c-ff9m, MINI-2hw5-q54p-wmhp, MINI-447h-q994-qm5g, MINI-47pp-g4wv-mrrq, MINI-48ww-j2gr-x7cx, MINI-67wg-mrmh-2mj2, MINI-6fj3-vf4c-32jh, MINI-6mx5-x65q-43g3, MINI-73rj-h2g3-cr5r, MINI-7gqj-pc63-r8cp, MINI-89jv-8mqp-xph8, MINI-99xj-mq9h-997v, MINI-9r8q-h3r2-cv2m, MINI-c6px-jm5p-hgm7, MINI-f3gc-5hjr-v698, MINI-f65q-jjjm-63g9, MINI-fhwx-wjrg-xgqc, MINI-g848-fhqc-c6hq, MINI-gm3f-x9g5-hp96, MINI-h8f4-466m-977g, MINI-h9xv-765g-jrvp, MINI-hxw8-8cjq-fgxc, MINI-jf33-487f-3vcw, MINI-m5cp-4hx9-8x49, MINI-m9pc-9w9p-4wmq, MINI-pm7m-5qp3-w392, MINI-rh6m-6gg8-82x6, MINI-wq9h-fjpg-3f9q, MINI-x5pv-p73j-77pv, MINI-xx44-pfvw-w98x, ROOT-APP-MAVEN-CVE-2026-35554

## What is CVE-2026-35554?

CVE-2026-35554 is a high-severity vulnerability in Apache Kafka Clients, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A race condition in the Apache Kafka Java producer client’s buffer pool management can cause messages to be silently delivered to incorrect topics.

When a produce batch expires due to delivery.timeout.ms while a network request containing that batch is still in flight, the batch’s ByteBuffer is prematurely deallocated and returned to the buffer pool. If a subsequent producer batch—potentially destined for a different topic—reuses this freed buffer before the original network request completes, the buffer contents may become corrupted. This can result in messages being delivered to unintended topics without any error being reported to the producer.

Data Confidentiality:
Messages intended for one topic may be delivered to a different topic, potentially exposing sensitive data to consumers who have access to the destination topic but not the intended source topic.

Data Integrity:
Consumers on the receiving topic may encounter unexpected or incompatible messages, leading to deserialization failures, processing errors, and corrupted downstream data.

This issue affects Apache Kafka versions ≤ 3.9.1, ≤ 4.0.1, and  ≤ 4.1.1.

Kafka users are advised to upgrade to 3.9.2, 4.0.2, 4.1.2, 4.2.0, or later to address this vulnerability.

Weakness: CWE-416 (Use After Free), CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-35554?

6 open source packages ship an affected version, including org.apache.kafka:kafka-clients. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kafka:kafka-clients` | Maven | From 2.8.0 | 3.9.2 |
| `org.apache.kafka:kafka-clients` | Maven | From 2.8.0 | 3.9.2 |
| `org.apache.kafka:kafka-clients` | Maven | From 4.0.0 | 4.0.2 |
| `org.apache.kafka:kafka-clients` | Maven | From 4.0.0 | 4.0.2 |
| `org.apache.kafka:kafka-clients` | Maven | From 4.1.0 | 4.1.2 |
| `org.apache.kafka:kafka-clients` | Maven | From 4.1.0 | 4.1.2 |

Products: Apache Kafka.

## How do I fix CVE-2026-35554?

Upgrade org.apache.kafka:kafka-clients to a fixed version for your release line: 3.9.2, 4.0.2 or 4.1.2.

## Is CVE-2026-35554 being exploited?

There is no known exploitation of CVE-2026-35554 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kafka Clients

- [CVE-2026-33557](https://insights.sbomify.com/CVE-2026-33557/): Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication (critical 9.1)
- [CVE-2025-27818](https://insights.sbomify.com/CVE-2025-27818/): Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration (high 8.8)
- [CVE-2018-17196](https://insights.sbomify.com/CVE-2018-17196/): Improper Input Validation in Apache Kafka (high 8.8)
- [CVE-2025-27817](https://insights.sbomify.com/CVE-2025-27817/): Apache Kafka Client: Arbitrary file read and SSRF vulnerability (high 7.5)
- [CVE-2025-27819](https://insights.sbomify.com/CVE-2025-27819/): Apache Kafka: Possible RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35554 and fix it if it is affected.

What it is: CVE-2026-35554 is a high-severity vulnerability in Apache Kafka Clients, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35554 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kafka:kafka-clients (Maven): affected from 2.8.0; fixed in 3.9.2
- org.apache.kafka:kafka-clients (Maven): affected from 2.8.0; fixed in 3.9.2
- org.apache.kafka:kafka-clients (Maven): affected from 4.0.0; fixed in 4.0.2
- org.apache.kafka:kafka-clients (Maven): affected from 4.0.0; fixed in 4.0.2
- org.apache.kafka:kafka-clients (Maven): affected from 4.1.0; fixed in 4.1.2
- org.apache.kafka:kafka-clients (Maven): affected from 4.1.0; fixed in 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35554/ (Markdown: https://insights.sbomify.com/CVE-2026-35554/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35554
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35554
- OSV: https://osv.dev/vulnerability/CVE-2026-35554

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35554/
Summaries are generated and may contain mistakes; the official description above is the record.
