# CVE-2026-35565: Apache Storm UI: Stored Cross-Site Scripting (XSS) via Unsanitized Topology Metadata in Storm UI

> Authenticated users can inject malicious scripts via topology metadata, leading to code execution and privilege escalation in admin browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-f2hp-qw27-8wfq

## What is CVE-2026-35565?

CVE-2026-35565 is a medium-severity cross-site scripting vulnerability in Apache Storm UI, published on 13 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Stored Cross-Site Scripting (XSS) via Unsanitized Topology Metadata in Apache Storm UI

Versions Affected: before 2.8.6

Description: The Storm UI visualization component interpolates topology metadata including component IDs, stream names, and grouping values directly into HTML via innerHTML in parseNode() and parseEdge() without sanitization at any layer. An authenticated user with topology submission rights could craft a topology containing malicious HTML/JavaScript in component identifiers (e.g., a bolt ID containing an onerror event handler). This payload flows through Nimbus → Thrift → the Visualization API → vis.js tooltip rendering, resulting in stored cross-site scripting. 

In multi-tenant deployments where topology submission is available to less-trusted users but the UI is accessed by operators or administrators, this enables privilege escalation through script execution in an admin's browser session.

Mitigation: 2.x users should upgrade to 2.8.6. Users who cannot upgrade immediately should monkey-patch the parseNode() and parseEdge() functions in the visualization JavaScript file to HTML-escape all API-supplied values including nodeId, :capacity, :latency, :component, :stream, and :grouping before interpolation into tooltip HTML strings, and should additionally restrict topology submission to trusted users via Nimbus ACLs as a defense-in-depth measure. A guide on how to do this is available in the release notes of 2.8.6.

Credit: This issue was discovered while investigating another report by K.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-35565?

2 open source packages ship an affected version, including org.apache.storm:storm-webapp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.storm:storm-webapp` | Maven | All versions | 2.8.6 |
| `org.apache.storm:storm-webapp` | Maven | All versions | 2.8.6 |

Products: Apache Storm.

## How do I fix CVE-2026-35565?

Upgrade org.apache.storm:storm-webapp to 2.8.6 or later.

## Is CVE-2026-35565 being exploited?

There is no known exploitation of CVE-2026-35565 in the wild and no public exploit code.

## Other vulnerabilities in Apache Storm UI

- [CVE-2021-38294](https://insights.sbomify.com/CVE-2021-38294/): Shell Command Injection Vulnerability in Nimbus Thrift Server (critical 9.8)
- [CVE-2021-40865](https://insights.sbomify.com/CVE-2021-40865/): Unsafe Pre-Authentication Deserialization In Workers (critical 9.8)
- [CVE-2018-11779](https://insights.sbomify.com/CVE-2018-11779/): Deserialization of Untrusted Data in Apache Storm (critical 9.8)
- [CVE-2015-3188](https://insights.sbomify.com/CVE-2015-3188/): Apache Storm remote code execution vulnerability (critical 9.8)
- [CVE-2026-35337](https://insights.sbomify.com/CVE-2026-35337/): Apache Storm Client: RCE through Unsafe Deserialization via Kerberos TGT Credential Handling (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35565 and fix it if it is affected.

What it is: CVE-2026-35565 is a medium-severity cross-site scripting vulnerability in Apache Storm UI, published on 13 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-35565 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.storm:storm-webapp (Maven): affected all versions; fixed in 2.8.6
- org.apache.storm:storm-webapp (Maven): affected all versions; fixed in 2.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35565/ (Markdown: https://insights.sbomify.com/CVE-2026-35565/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35565
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35565
- OSV: https://osv.dev/vulnerability/CVE-2026-35565

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35565/
Summaries are generated and may contain mistakes; the official description above is the record.
