CVE-2026-35569 ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS

High 8.7 Published Updated

Stored XSS in ApostropheCMS SEO fields allows attackers to execute scripts and exfiltrate sensitive user data from authenticated sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-35569?

CVE-2026-35569 is a high-severity cross-site scripting vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain a stored cross-site scripting vulnerability in SEO-related fields (SEO Title and Meta Description), where user-controlled input is rendered without proper output encoding into HTML contexts including <title> tags, <meta> attributes, and JSON-LD structured data. An attacker can inject a payload such as "></title><script>alert(1)</script> to break out of the intended HTML context and execute arbitrary JavaScript in the browser of any authenticated user who views the affected page. This can be leveraged to perform authenticated API requests, access sensitive data such as usernames, email addresses, and roles via internal APIs, and exfiltrate it to an attacker-controlled server. This issue has been fixed in version 4.29.0.

Weakness: CWE-79, CWE-116

Which versions are affected by CVE-2026-35569?

2 open source packages ship an affected version, including apostrophe. It affects 1 product.

PackageAffectedFixed in
apostrophe npmAll versions4.29.0
apostrophe npmAll versions4.29.0

Products include Apostrophecms Apostrophecms.

How do I fix CVE-2026-35569?

Upgrade apostrophe to 4.29.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-35569 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35569 exists.

Sources

Also known as GHSA-855c-r2vq-c292.

Is CVE-2026-35569 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free