# CVE-2026-35569: ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS

> Stored XSS in ApostropheCMS SEO fields allows attackers to execute scripts and exfiltrate sensitive user data from authenticated sessions.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-855c-r2vq-c292

## What is CVE-2026-35569?

CVE-2026-35569 is a high-severity cross-site scripting vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain a stored cross-site scripting vulnerability in SEO-related fields (SEO Title and Meta Description), where user-controlled input is rendered without proper output encoding into HTML contexts including <title> tags, <meta> attributes, and JSON-LD structured data. An attacker can inject a payload such as "></title><script>alert(1)</script> to break out of the intended HTML context and execute arbitrary JavaScript in the browser of any authenticated user who views the affected page. This can be leveraged to perform authenticated API requests, access sensitive data such as usernames, email addresses, and roles via internal APIs, and exfiltrate it to an attacker-controlled server. This issue has been fixed in version 4.29.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-35569?

2 open source packages ship an affected version, including apostrophe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.29.0 |
| `apostrophe` | npm | All versions | 4.29.0 |

Products: Apostrophecms Apostrophecms.

## How do I fix CVE-2026-35569?

Upgrade apostrophe to 4.29.0 or later.

## Is CVE-2026-35569 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35569 exists.

## Other vulnerabilities in apostrophecms apostrophe

- [CVE-2021-25979](https://insights.sbomify.com/CVE-2021-25979/): Apostrophe - Insufficient Session Expiration (critical 9.8)
- [CVE-2026-32730](https://insights.sbomify.com/CVE-2026-32730/): ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware (high 8.1)
- [CVE-2026-40186](https://insights.sbomify.com/CVE-2026-40186/): ApostropheCMS: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements (medium 6.1)
- [CVE-2026-33889](https://insights.sbomify.com/CVE-2026-33889/): ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context (medium 5.4)
- [CVE-2021-25978](https://insights.sbomify.com/CVE-2021-25978/): Apostrophe - XSS (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35569 and fix it if it is affected.

What it is: CVE-2026-35569 is a high-severity cross-site scripting vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35569 exists.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.29.0
- apostrophe (npm): affected all versions; fixed in 4.29.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35569/ (Markdown: https://insights.sbomify.com/CVE-2026-35569/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35569
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35569
- OSV: https://osv.dev/vulnerability/CVE-2026-35569

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35569/
Summaries are generated and may contain mistakes; the official description above is the record.
