# CVE-2026-35582: Emissary has an OS Command Injection via Unvalidated IN_FILE_ENDING / OUT_FILE_ENDING in Executrix

> A place configuration author can inject shell commands via unvalidated file ending parameters in Emissary, leading to arbitrary code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** GHSA-3p24-9x7v-7789

## What is CVE-2026-35582?

CVE-2026-35582 is a high-severity command injection vulnerability in NationalSecurityAgency emissary, published on 18 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Emissary is a P2P based data-driven workflow engine. In versions 8.42.0 and below, Executrix.getCommand() is vulnerable to OS command injection  because it interpolates temporary file paths into a /bin/sh -c shell command string without any escaping or input validation. The IN_FILE_ENDING and OUT_FILE_ENDING configuration keys flow directly into these paths, allowing a place author who can write or modify a .cfg file to inject arbitrary shell metacharacters that execute OS commands in the JVM process's security context. The framework already sanitizes placeName via an allowlist before embedding it in the same shell string, but applies no equivalent sanitization to file ending values. No runtime privileges beyond place configuration authorship, and no API or network access, are required to exploit this vulnerability. This is a framework-level defect with no safe mitigation available to downstream implementors, as Executrix provides neither escaping nor documented preconditions against metacharacters in file ending inputs. This issue has been fixed in version 8.43.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-35582?

2 open source packages ship an affected version, including gov.nsa.emissary:emissary. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gov.nsa.emissary:emissary` | Maven | All versions | 8.43.0 |
| `gov.nsa.emissary:emissary` | Maven | All versions | 8.43.0 |

Products: Nsa Emissary.

## How do I fix CVE-2026-35582?

Upgrade gov.nsa.emissary:emissary to 8.43.0 or later.

## Is CVE-2026-35582 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35582 exists.

## Other vulnerabilities in NationalSecurityAgency emissary

- [CVE-2026-35580](https://insights.sbomify.com/CVE-2026-35580/): Emissary has GitHub Actions Shell Injection via Workflow Inputs (critical 9.1)
- [CVE-2021-32094](https://insights.sbomify.com/CVE-2021-32094/): File upload in n/a (high 8.8)
- [CVE-2021-32096](https://insights.sbomify.com/CVE-2021-32096/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2021-32095](https://insights.sbomify.com/CVE-2021-32095/): Missing authorization in n/a (high 8.1)
- [CVE-2021-32647](https://insights.sbomify.com/CVE-2021-32647/): Post-authentication Remote Code Execution (RCE) in emissary:emissary (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35582 and fix it if it is affected.

What it is: CVE-2026-35582 is a high-severity command injection vulnerability in NationalSecurityAgency emissary, published on 18 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35582 exists.

Affected packages and fixed versions:
- gov.nsa.emissary:emissary (Maven): affected all versions; fixed in 8.43.0
- gov.nsa.emissary:emissary (Maven): affected all versions; fixed in 8.43.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35582/ (Markdown: https://insights.sbomify.com/CVE-2026-35582/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35582
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35582
- OSV: https://osv.dev/vulnerability/CVE-2026-35582

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35582/
Summaries are generated and may contain mistakes; the official description above is the record.
