{"answers":{"affected":"3 open source packages ship an affected version, including glances. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35587 exists.","fix":"Upgrade glances to 4.5.4 or later.","what":"CVE-2026-35587 is a high-severity server-side request forgery vulnerability in nicolargo glances, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-35587 and fix it if it is affected.\n\nWhat it is: CVE-2026-35587 is a high-severity server-side request forgery vulnerability in nicolargo glances, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35587 exists.\n\nAffected packages and fixed versions:\n- glances (PyPI): affected all versions; fixed in 4.5.4\n- glances (PyPI): affected all versions; fixed in 4.5.4\n- glances (PyPI): affected all versions; fixed in 4.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-35587/ (Markdown: https://insights.sbomify.com/CVE-2026-35587/index.md)","id":"CVE-2026-35587","markdown":"https://insights.sbomify.com/CVE-2026-35587/index.md","name":"CVE-2026-35587","record":{"aliases":["DEBIAN-CVE-2026-35587","GHSA-g5pq-48mj-jvw8","PYSEC-2026-2176","UBUNTU-CVE-2026-35587"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"System monitoring tool","requires_auth":"low_privilege","summary":"Attackers with config access can trigger SSRF to leak credentials and access internal services via the Glances IP plugin.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"glances","vendor":"nicolargo"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.4, a Server-Side Request Forgery (SSRF) vulnerability exists in the Glances IP plugin due to improper validation of the public_api configuration parameter. The value of public_api is used directly in outbound HTTP requests without any scheme restriction or hostname/IP validation. An attacker who can modify the Glances configuration can force the application to send requests to arbitrary internal or external endpoints. Additionally, when public_username and public_password are set, Glances automatically includes these credentials in the Authorization: Basic header, resulting in credential leakage to attacker-controlled servers. This vulnerability can be exploited to access internal network services, retrieve sensitive data from cloud metadata endpoints, and/or exfiltrate credentials via outbound HTTP requests. The issue arises because public_api is passed directly to the HTTP client (urlopen_auth) without validation, allowing unrestricted outbound connections and unintended disclosure of sensitive information. Version 4.5.4 contains a patch.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Glances IP Plugin has SSRF via public_api that leads to credential leakage","id":"CVE-2026-35587","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Glances has CQL Injection in its Cassandra Export Module via Unsanitized Config Values","id":"CVE-2026-35588"},"packages":[{"ecosystem":"PyPI","fixed":["4.5.4"],"introduced":["0"],"last_affected":[],"package":"glances","purl":null,"source":"GHSA-g5pq-48mj-jvw8"},{"ecosystem":"PyPI","fixed":["4.5.4"],"introduced":["0"],"last_affected":[],"package":"glances","purl":"pkg:pypi/glances","source":"GHSA-g5pq-48mj-jvw8"},{"ecosystem":"PyPI","fixed":["4.5.4"],"introduced":["0"],"last_affected":[],"package":"glances","purl":"pkg:pypi/glances","source":"PYSEC-2026-2176"}],"prev":{"headline":"Authorization Bypass for SSL Certificate/Key Configuration Due to Option Name Mismatch in pyload-ng","id":"CVE-2026-35586"},"products":["glances"],"published":"2026-04-20","related":[{"cvss_score":9.1,"headline":"Glances's Browser API Exposes Reusable Downstream Credentials via `/api/4/serverslist`","id":"CVE-2026-32633","kev_date_added":null,"published":"2026-03-18"},{"cvss_score":8.7,"headline":"Glances exposes the REST API without authentication","id":"CVE-2026-32596","kev_date_added":null,"published":"2026-03-18"},{"cvss_score":8.7,"headline":"Glances Exposes Unauthenticated Configuration Secrets","id":"CVE-2026-30928","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":8.1,"headline":"Glances's Default CORS Configuration Allows Cross-Origin Credential Theft","id":"CVE-2026-32610","kev_date_added":null,"published":"2026-03-18"},{"cvss_score":8.1,"headline":"Glances Central Browser Autodiscovery Leaks Reusable Credentials to Zeroconf-Spoofed Servers","id":"CVE-2026-32634","kev_date_added":null,"published":"2026-03-18"},{"cvss_score":7.8,"headline":"Glances Vulnerable to Command Injection via Dynamic Configuration Values","id":"CVE-2026-33641","kev_date_added":null,"published":"2026-04-02"},{"cvss_score":7.7,"headline":"Glances Vulnerable to Cross-Origin Information Disclosure via Unauthenticated REST API (/api/4) due to Permissive CORS","id":"CVE-2026-34839","kev_date_added":null,"published":"2026-04-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-22","vendors":["nicolargo"]},"summary":"Attackers with config access can trigger SSRF to leak credentials and access internal services via the Glances IP plugin.","url":"https://insights.sbomify.com/CVE-2026-35587/"}