# CVE-2026-35587: Glances IP Plugin has SSRF via public_api that leads to credential leakage

> Attackers with config access can trigger SSRF to leak credentials and access internal services via the Glances IP plugin.

- **Severity:** High 7.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-35587, GHSA-g5pq-48mj-jvw8, PYSEC-2026-2176, UBUNTU-CVE-2026-35587

## What is CVE-2026-35587?

CVE-2026-35587 is a high-severity server-side request forgery vulnerability in nicolargo glances, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.4, a Server-Side Request Forgery (SSRF) vulnerability exists in the Glances IP plugin due to improper validation of the public_api configuration parameter. The value of public_api is used directly in outbound HTTP requests without any scheme restriction or hostname/IP validation. An attacker who can modify the Glances configuration can force the application to send requests to arbitrary internal or external endpoints. Additionally, when public_username and public_password are set, Glances automatically includes these credentials in the Authorization: Basic header, resulting in credential leakage to attacker-controlled servers. This vulnerability can be exploited to access internal network services, retrieve sensitive data from cloud metadata endpoints, and/or exfiltrate credentials via outbound HTTP requests. The issue arises because public_api is passed directly to the HTTP client (urlopen_auth) without validation, allowing unrestricted outbound connections and unintended disclosure of sensitive information. Version 4.5.4 contains a patch.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-35587?

3 open source packages ship an affected version, including glances. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glances` | PyPI | All versions | 4.5.4 |
| `glances` | PyPI | All versions | 4.5.4 |
| `glances` | PyPI | All versions | 4.5.4 |

Products: Nicolargo Glances.

## How do I fix CVE-2026-35587?

Upgrade glances to 4.5.4 or later.

## Is CVE-2026-35587 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35587 exists.

## Other vulnerabilities in nicolargo glances

- [CVE-2026-32633](https://insights.sbomify.com/CVE-2026-32633/): Glances's Browser API Exposes Reusable Downstream Credentials via `/api/4/serverslist` (critical 9.1)
- [CVE-2026-32596](https://insights.sbomify.com/CVE-2026-32596/): Glances exposes the REST API without authentication (high 8.7)
- [CVE-2026-30928](https://insights.sbomify.com/CVE-2026-30928/): Glances Exposes Unauthenticated Configuration Secrets (high 8.7)
- [CVE-2026-32610](https://insights.sbomify.com/CVE-2026-32610/): Glances's Default CORS Configuration Allows Cross-Origin Credential Theft (high 8.1)
- [CVE-2026-32634](https://insights.sbomify.com/CVE-2026-32634/): Glances Central Browser Autodiscovery Leaks Reusable Credentials to Zeroconf-Spoofed Servers (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35587 and fix it if it is affected.

What it is: CVE-2026-35587 is a high-severity server-side request forgery vulnerability in nicolargo glances, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35587 exists.

Affected packages and fixed versions:
- glances (PyPI): affected all versions; fixed in 4.5.4
- glances (PyPI): affected all versions; fixed in 4.5.4
- glances (PyPI): affected all versions; fixed in 4.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35587/ (Markdown: https://insights.sbomify.com/CVE-2026-35587/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35587
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35587
- OSV: https://osv.dev/vulnerability/CVE-2026-35587

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35587/
Summaries are generated and may contain mistakes; the official description above is the record.
