# CVE-2026-35590: Possible out-of-bounds read leading to crash when decoding well-crafted EXIF metadata

> Attackers can cause a crash in libvips by providing crafted EXIF metadata, requiring an upgrade to the patched version.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** CLEANSTART-2026-HI83908, DEBIAN-CVE-2026-35590, GHSA-jmwm-wc68-mhwm, UBUNTU-CVE-2026-35590

## What is CVE-2026-35590?

CVE-2026-35590 is a medium-severity vulnerability in libvips, published on 20 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

libvips is a fast image processing library with low memory needs. The EXIF decoder within libvips versions before and including 8.18.1 was not verifying the range of EXIF tag groups before passing data to libexif, leading to a possible null pointer dereference and crash. This has been patched in version 8.18.2.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-35590?

It affects 1 product.


Products: Libvips Libvips.

## How do I fix CVE-2026-35590?

Upgrade to a fixed version.

## Is CVE-2026-35590 being exploited?

There is no known exploitation of CVE-2026-35590 in the wild and no public exploit code.

## Other vulnerabilities in libvips

- [CVE-2019-17534](https://insights.sbomify.com/CVE-2019-17534/): Use after free in n/a (high 8.8)
- [CVE-2026-33327](https://insights.sbomify.com/CVE-2026-33327/): Possible integer overflow leading to potential heap-based buffer overflow (high 7.0)
- [CVE-2026-35591](https://insights.sbomify.com/CVE-2026-35591/): Possible heap-based buffer overflow when decoding TIFF image containing well-crafted tile (high 7.0)
- [CVE-2026-33328](https://insights.sbomify.com/CVE-2026-33328/): Possible integer overflow on 32-bit systems when reading GIF images (medium 6.8)
- [CVE-2021-27847](https://insights.sbomify.com/CVE-2021-27847/): Denial of service in n/a (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35590 and fix it if it is affected.

What it is: CVE-2026-35590 is a medium-severity vulnerability in libvips, published on 20 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35590 in the wild and no public exploit code.

Affected product: libvips. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35590/ (Markdown: https://insights.sbomify.com/CVE-2026-35590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35590
- OSV: https://osv.dev/vulnerability/CVE-2026-35590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35590/
Summaries are generated and may contain mistakes; the official description above is the record.
