# CVE-2026-35603: Claude Code: Insecure System-Wide Configuration Loading Enables Local Privilege Escalation on Windows

> A local attacker can escalate privileges by placing a malicious configuration file in a writable system directory, which is then loaded by other users.

- **Severity:** Medium 5.4 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** GHSA-5cwg-9f6j-9jvx, MINI-qrr7-fm24-57q7, MINI-rfw4-vr5x-x6xr

## What is CVE-2026-35603?

CVE-2026-35603 is a medium-severity vulnerability in anthropics claude-code, published on 17 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Claude Code is an agentic coding tool. In versions prior to 2.1.75 on Windows, Claude Code loaded the system-wide default configuration from C:\ProgramData\ClaudeCode\managed-settings.json without validating directory ownership or access permissions. Because the ProgramData directory is writable by non-administrative users by default and the ClaudeCode subdirectory was not pre-created or access-restricted, a low-privileged local user could create this directory and place a malicious configuration file that would be automatically loaded for any user launching Claude Code on the same machine. Exploiting this would have required a shared multi-user Windows system and a victim user to launch Claude Code after the malicious configuration was placed. This issue has been fixed on version 2.1.75.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2026-35603?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | All versions | 2.1.75 |
| `@anthropic-ai/claude-code` | npm | All versions | 2.1.75 |

Products: Anthropic Claude Code.

## How do I fix CVE-2026-35603?

Upgrade @anthropic-ai/claude-code to 2.1.75 or later.

## Is CVE-2026-35603 being exploited?

There is no known exploitation of CVE-2026-35603 in the wild and no public exploit code.

Public exploit code:

- Detection & remediation toolkit for the Miasma / Shai-Hulud worm and CVE-2026-35603 (AI-agent/IDE config injection) (github_poc): https://github.com/jchable/miasma-toolkit

## Other vulnerabilities in anthropics claude-code

- [CVE-2025-66032](https://insights.sbomify.com/CVE-2025-66032/): Claude Code Command Validation Bypass Allows Arbitrary Code Execution (high 8.7)
- [CVE-2025-64755](https://insights.sbomify.com/CVE-2025-64755/): @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes (high 8.7)
- [CVE-2025-59536](https://insights.sbomify.com/CVE-2025-59536/): Claude Code's startup trust dialog could lead to Command Execution attack (high 8.7)
- [CVE-2025-58764](https://insights.sbomify.com/CVE-2025-58764/): Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution (high 8.7)
- [CVE-2025-59041](https://insights.sbomify.com/CVE-2025-59041/): Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35603 and fix it if it is affected.

What it is: CVE-2026-35603 is a medium-severity vulnerability in anthropics claude-code, published on 17 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-35603 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.1.75
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.1.75

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35603/ (Markdown: https://insights.sbomify.com/CVE-2026-35603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35603
- OSV: https://osv.dev/vulnerability/CVE-2026-35603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35603/
Summaries are generated and may contain mistakes; the official description above is the record.
