{"answers":{"affected":"2 open source packages ship an affected version, including addressable. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-35611 in the wild and no public exploit code.","fix":"Upgrade addressable to 2.9.0 or later.","what":"CVE-2026-35611 is a high-severity denial of service vulnerability in sporkmonger addressable, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-35611 and fix it if it is affected.\n\nWhat it is: CVE-2026-35611 is a high-severity denial of service vulnerability in sporkmonger addressable, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-35611 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- addressable (RubyGems): affected from 2.3.0; fixed in 2.9.0\n- addressable (RubyGems): affected from 2.3.0; fixed in 2.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-35611/ (Markdown: https://insights.sbomify.com/CVE-2026-35611/index.md)","id":"CVE-2026-35611","markdown":"https://insights.sbomify.com/CVE-2026-35611/index.md","name":"CVE-2026-35611","record":{"aliases":["AZL-82061","DEBIAN-CVE-2026-35611","GHSA-h27x-rffw-24p4","MINI-29c2-cwwf-rg25","MINI-2m2f-hfp2-84w9","MINI-3434-m2rw-cfp6","MINI-36q6-jv2v-w4gg","MINI-3jf8-3j8j-x3qp","MINI-3qww-r79m-f2rc","MINI-4hgq-5689-6c43","MINI-4xx8-35fq-26gg","MINI-5w6x-mr9v-prvx","MINI-6cc5-gxv4-6gfx","MINI-6v35-fw8h-4w7p","MINI-957j-4778-h92x","MINI-9xxf-x63w-fx7r","MINI-c498-r2c5-qvfv","MINI-crj5-hvcw-r686","MINI-f37v-2qgq-3j2g","MINI-fx5x-vpmq-r3hm","MINI-g342-mp7j-7cw5","MINI-jh57-868p-mgmg","MINI-r9r3-j9pf-cg28","MINI-vxh8-33j5-v4hq","MINI-x9r9-jf3v-3pr8","OESA-2026-1967","UBUNTU-CVE-2026-35611","USN-8515-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby URI library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using Addressable by submitting malicious URIs that trigger catastrophic backtracking in URI template regexes.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"addressable","vendor":"addressable_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"Addressable is an alternative implementation to the URI implementation that is part of Ruby's standard library. From 2.3.0 to before 2.9.0, within the URI template implementation in Addressable, two classes of URI template generate regular expressions vulnerable to catastrophic backtracking. Templates using the * (explode) modifier with any expansion operator (e.g., {foo*}, {+var*}, {#var*}, {/var*}, {.var*}, {;var*}, {?var*}, {\u0026var*}) generate patterns with nested unbounded quantifiers that are O(2^n) when matched against a maliciously crafted URI. Templates using multiple variables with the + or # operators (e.g., {+v1,v2,v3}) generate patterns with O(n^k) complexity due to the comma separator being within the matched character class, causing ambiguous backtracking across k variables. When matched against a maliciously crafted URI, this can result in catastrophic backtracking and uncontrolled resource consumption, leading to denial of service. This vulnerability is fixed in 2.9.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Addressable has a Regular Expression Denial of Service in Addressable templates","id":"CVE-2026-35611","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Path traversal in coursevault-preview due to improper base-directory boundary validation","id":"CVE-2026-35613"},"packages":[{"ecosystem":"RubyGems","fixed":["2.9.0"],"introduced":["2.3.0"],"last_affected":[],"package":"addressable","purl":null,"source":"GHSA-h27x-rffw-24p4"},{"ecosystem":"RubyGems","fixed":["2.9.0"],"introduced":["2.3.0"],"last_affected":[],"package":"addressable","purl":"pkg:gem/addressable","source":"GHSA-h27x-rffw-24p4"}],"prev":{"headline":"PolarLearn has a Server Action Admin Bypass in Account Management Actions","id":"CVE-2026-35610"},"products":["addressable"],"published":"2026-04-07","related":[{"cvss_score":7.5,"headline":"Regular Expression Denial of Service in Addressable templates","id":"CVE-2021-32740","kev_date_added":null,"published":"2021-07-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-09","vendors":["sporkmonger"]},"summary":"Attackers can cause denial of service in applications using Addressable by submitting malicious URIs that trigger catastrophic backtracking in URI template regexes.","url":"https://insights.sbomify.com/CVE-2026-35611/"}