# CVE-2026-35611: Addressable has a Regular Expression Denial of Service in Addressable templates

> Attackers can cause denial of service in applications using Addressable by submitting malicious URIs that trigger catastrophic backtracking in URI template regexes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** AZL-82061, DEBIAN-CVE-2026-35611, GHSA-h27x-rffw-24p4, MINI-29c2-cwwf-rg25, MINI-2m2f-hfp2-84w9, MINI-3434-m2rw-cfp6, MINI-36q6-jv2v-w4gg, MINI-3jf8-3j8j-x3qp, MINI-3qww-r79m-f2rc, MINI-4hgq-5689-6c43, MINI-4xx8-35fq-26gg, MINI-5w6x-mr9v-prvx, MINI-6cc5-gxv4-6gfx, MINI-6v35-fw8h-4w7p, MINI-957j-4778-h92x, MINI-9xxf-x63w-fx7r, MINI-c498-r2c5-qvfv, MINI-crj5-hvcw-r686, MINI-f37v-2qgq-3j2g, MINI-fx5x-vpmq-r3hm, MINI-g342-mp7j-7cw5, MINI-jh57-868p-mgmg, MINI-r9r3-j9pf-cg28, MINI-vxh8-33j5-v4hq, MINI-x9r9-jf3v-3pr8, OESA-2026-1967, UBUNTU-CVE-2026-35611, USN-8515-1

## What is CVE-2026-35611?

CVE-2026-35611 is a high-severity denial of service vulnerability in sporkmonger addressable, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Addressable is an alternative implementation to the URI implementation that is part of Ruby's standard library. From 2.3.0 to before 2.9.0, within the URI template implementation in Addressable, two classes of URI template generate regular expressions vulnerable to catastrophic backtracking. Templates using the * (explode) modifier with any expansion operator (e.g., {foo*}, {+var*}, {#var*}, {/var*}, {.var*}, {;var*}, {?var*}, {&var*}) generate patterns with nested unbounded quantifiers that are O(2^n) when matched against a maliciously crafted URI. Templates using multiple variables with the + or # operators (e.g., {+v1,v2,v3}) generate patterns with O(n^k) complexity due to the comma separator being within the matched character class, causing ambiguous backtracking across k variables. When matched against a maliciously crafted URI, this can result in catastrophic backtracking and uncontrolled resource consumption, leading to denial of service. This vulnerability is fixed in 2.9.0.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-35611?

2 open source packages ship an affected version, including addressable. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `addressable` | RubyGems | From 2.3.0 | 2.9.0 |
| `addressable` | RubyGems | From 2.3.0 | 2.9.0 |

Products: Addressable Project Addressable.

## How do I fix CVE-2026-35611?

Upgrade addressable to 2.9.0 or later.

## Is CVE-2026-35611 being exploited?

There is no known exploitation of CVE-2026-35611 in the wild and no public exploit code.

## Other vulnerabilities in sporkmonger addressable

- [CVE-2021-32740](https://insights.sbomify.com/CVE-2021-32740/): Regular Expression Denial of Service in Addressable templates (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35611 and fix it if it is affected.

What it is: CVE-2026-35611 is a high-severity denial of service vulnerability in sporkmonger addressable, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35611 in the wild and no public exploit code.

Affected packages and fixed versions:
- addressable (RubyGems): affected from 2.3.0; fixed in 2.9.0
- addressable (RubyGems): affected from 2.3.0; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35611/ (Markdown: https://insights.sbomify.com/CVE-2026-35611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35611
- OSV: https://osv.dev/vulnerability/CVE-2026-35611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35611/
Summaries are generated and may contain mistakes; the official description above is the record.
