CVE-2026-35617 OpenClaw < 2026.3.25 - Authorization Bypass via Group Policy Rebinding with Mutable Space displayName

Low 2.3 Published Updated

Attackers can bypass authorization in OpenClaw by manipulating space display names to gain unauthorized access to protected resources.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-35617?

CVE-2026-35617 is a low-severity authentication bypass vulnerability in Openclaw Openclaw, published on 9 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

OpenClaw before 2026.3.25 contains an authorization bypass vulnerability in Google Chat group policy enforcement that relies on mutable space display names. Attackers can rebind group policies by changing or colliding space display names to gain unauthorized access to protected resources.

Weakness: CWE-807

Which versions are affected by CVE-2026-35617?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmAll versions2026.3.28
openclaw npmAll versions2026.3.28

Products include Openclaw Openclaw.

How do I fix CVE-2026-35617?

Upgrade openclaw to 2026.3.28 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-35617 being exploited?

There is no known exploitation of CVE-2026-35617 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-52q4-3xjc-6778, MINI-c3rr-mx77-h972, MINI-m899-qjh2-g987.

Is CVE-2026-35617 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free