# CVE-2026-35621: OpenClaw < 2026.3.24 - Privilege Escalation via chat.send to Allowlist Persistence

> Attackers with operator.write scope can escalate privileges to modify channel authorization policies via chat.send, requiring an upgrade to OpenClaw.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-94pw-c6m8-p9p9, MINI-c7f4-rmfw-7966

## What is CVE-2026-35621?

CVE-2026-35621 is a high-severity vulnerability in Openclaw Openclaw, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw before 2026.3.24 contains a privilege escalation vulnerability where the /allowlist command fails to re-validate gateway client scopes for internal callers, allowing operator.write-scoped clients to mutate channel authorization policy. Attackers can exploit chat.send to build an internal command-authorized context and persist channel allowFrom and groupAllowFrom policy changes reserved for operator.admin scope.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-35621?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.3.24 |
| `openclaw` | npm | All versions | 2026.3.24 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-35621?

Upgrade openclaw to 2026.3.24 or later.

## Is CVE-2026-35621 being exploited?

There is no known exploitation of CVE-2026-35621 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35621 and fix it if it is affected.

What it is: CVE-2026-35621 is a high-severity vulnerability in Openclaw Openclaw, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35621 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.3.24
- openclaw (npm): affected all versions; fixed in 2026.3.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35621/ (Markdown: https://insights.sbomify.com/CVE-2026-35621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35621
- OSV: https://osv.dev/vulnerability/CVE-2026-35621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35621/
Summaries are generated and may contain mistakes; the official description above is the record.
