CVE-2026-35640 OpenClaw < 2026.3.25 - Denial of Service via Unauthenticated Webhook Request Parsing

Medium 6.9 Published Updated

Unauthenticated attackers can cause denial of service by sending malicious webhook requests that trigger resource-intensive JSON parsing before signature validation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-35640?

CVE-2026-35640 is a medium-severity denial of service vulnerability in Openclaw Openclaw, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenClaw before 2026.3.25 parses JSON request bodies before validating webhook signatures, allowing unauthenticated attackers to force resource-intensive parsing operations. Remote attackers can send malicious webhook requests to trigger denial of service by exhausting server resources through forced JSON parsing before signature rejection.

Weakness: CWE-696

Which versions are affected by CVE-2026-35640?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmAll versions2026.3.28
openclaw npmAll versions2026.3.28

Products include Openclaw Openclaw.

How do I fix CVE-2026-35640?

Upgrade openclaw to 2026.3.28 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-35640 being exploited?

There is no known exploitation of CVE-2026-35640 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-3h52-cx59-c456, MINI-8hm8-xfcg-qxj6.

Is CVE-2026-35640 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free