# CVE-2026-35641: OpenClaw < 2026.3.24 - Arbitrary Code Execution via .npmrc in Local Plugin/Hook Installation

> Attackers can execute arbitrary code by crafting a malicious .npmrc file during local plugin or hook installation in OpenClaw.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Apr 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-m3mh-3mpg-37hw, MINI-6vcp-hx65-v883

## What is CVE-2026-35641?

CVE-2026-35641 is a high-severity code injection vulnerability in Openclaw Openclaw, published on 10 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenClaw before 2026.3.24 contains an arbitrary code execution vulnerability in local plugin and hook installation that allows attackers to execute malicious code by crafting a .npmrc file with a git executable override. During npm install execution in the staged package directory, attackers can leverage git dependencies to trigger execution of arbitrary programs specified in the attacker-controlled .npmrc configuration file.

Weakness: CWE-349 (Acceptance of Extraneous Untrusted Data With Trusted Data)

## Which versions are affected by CVE-2026-35641?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.3.24 |
| `openclaw` | npm | All versions | 2026.3.24 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-35641?

Upgrade openclaw to 2026.3.24 or later.

## Is CVE-2026-35641 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35641 exists.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35641 and fix it if it is affected.

What it is: CVE-2026-35641 is a high-severity code injection vulnerability in Openclaw Openclaw, published on 10 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35641 exists.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.3.24
- openclaw (npm): affected all versions; fixed in 2026.3.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35641/ (Markdown: https://insights.sbomify.com/CVE-2026-35641/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35641
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35641
- OSV: https://osv.dev/vulnerability/CVE-2026-35641

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35641/
Summaries are generated and may contain mistakes; the official description above is the record.
