CVE-2026-35645 OpenClaw < 2026.3.25 - Privilege Escalation via Synthetic operator.admin in deleteSession

Medium 6.1 Published Updated

Attackers can escalate privileges to administrative scope by triggering session deletion in the OpenClaw gateway plugin, potentially executing privileged operations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-35645?

CVE-2026-35645 is a medium-severity vulnerability in Openclaw Openclaw, published on 9 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

OpenClaw before 2026.3.25 contains a privilege escalation vulnerability in the gateway plugin subagent fallback deleteSession function that uses a synthetic operator.admin runtime scope. Attackers can exploit this by triggering session deletion without a request-scoped client to execute privileged operations with unintended administrative scope.

Weakness: CWE-863, CWE-648

Which versions are affected by CVE-2026-35645?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmAll versions2026.3.28
openclaw npmAll versions2026.3.28

Products include Openclaw Openclaw.

How do I fix CVE-2026-35645?

Upgrade openclaw to 2026.3.28 or later.

Is CVE-2026-35645 being exploited?

There is no known exploitation of CVE-2026-35645 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-h4jx-hjr3-fhgc, MINI-9x63-cqj4-qmhv, MINI-m4j3-m5q5-f9q3.

Is CVE-2026-35645 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free