{"answers":{"affected":"2 open source packages ship an affected version, including openclaw. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-35645 in the wild and no public exploit code.","fix":"Upgrade openclaw to 2026.3.28 or later.","what":"CVE-2026-35645 is a medium-severity vulnerability in Openclaw Openclaw, published on 9 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-35645 and fix it if it is affected.\n\nWhat it is: CVE-2026-35645 is a medium-severity vulnerability in Openclaw Openclaw, published on 9 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-35645 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openclaw (npm): affected all versions; fixed in 2026.3.28\n- openclaw (npm): affected all versions; fixed in 2026.3.28\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-35645/ (Markdown: https://insights.sbomify.com/CVE-2026-35645/index.md)","id":"CVE-2026-35645","markdown":"https://insights.sbomify.com/CVE-2026-35645/index.md","name":"CVE-2026-35645","record":{"aliases":["GHSA-h4jx-hjr3-fhgc","MINI-9x63-cqj4-qmhv","MINI-m4j3-m5q5-f9q3"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenClaw gateway plugin","requires_auth":"low_privilege","summary":"Attackers can escalate privileges to administrative scope by triggering session deletion in the OpenClaw gateway plugin, potentially executing privileged operations.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"openclaw","vendor":"openclaw"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-648","name":"Incorrect Use of Privileged APIs"}],"description":"OpenClaw before 2026.3.25 contains a privilege escalation vulnerability in the gateway plugin subagent fallback deleteSession function that uses a synthetic operator.admin runtime scope. Attackers can exploit this by triggering session deletion without a request-scoped client to execute privileged operations with unintended administrative scope.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenClaw \u003c 2026.3.25 - Privilege Escalation via Synthetic operator.admin in deleteSession","id":"CVE-2026-35645","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"openclaw:openclaw","products":["openclaw:openclaw"],"type":"privilege_escalation","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"OpenClaw \u003c 2026.3.25 - Pre-Authentication Rate-Limit Bypass in Webhook Token Validation","id":"CVE-2026-35646"},"packages":[{"ecosystem":"npm","fixed":["2026.3.28"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":null,"source":"GHSA-h4jx-hjr3-fhgc"},{"ecosystem":"npm","fixed":["2026.3.28"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":"pkg:npm/openclaw","source":"GHSA-h4jx-hjr3-fhgc"}],"prev":{"headline":"OpenClaw \u003c 2026.3.22 - Credential Exposure via baseUrl Fields in Gateway Snapshots","id":"CVE-2026-35644"},"products":["OpenClaw"],"published":"2026-04-09","related":[{"cvss_score":9.9,"headline":"Security feature bypass in OpenClaw","id":"CVE-2026-28363","kev_date_added":null,"published":"2026-02-27"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-30741","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":9.4,"headline":"OpenClaw \u003c 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval","id":"CVE-2026-33579","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":9.4,"headline":"OpenClaw \u003c 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate","id":"CVE-2026-32922","kev_date_added":null,"published":"2026-03-29"},{"cvss_score":9.4,"headline":"OpenClaw \u003c 2026.3.11 - Approval Bypass via Unrecognized Script Runners","id":"CVE-2026-32978","kev_date_added":null,"published":"2026-03-29"},{"cvss_score":9.4,"headline":"OpenClaw \u003c 2026.3.12 - Scope Elevation in WebSocket Shared-Auth Connections","id":"CVE-2026-22172","kev_date_added":null,"published":"2026-03-20"},{"cvss_score":9.4,"headline":"OpenClaw \u003c 2026.2.14 - Remote Code Execution via Node Invoke Approval Bypass","id":"CVE-2026-28466","kev_date_added":null,"published":"2026-03-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["OpenClaw"]},"summary":"Attackers can escalate privileges to administrative scope by triggering session deletion in the OpenClaw gateway plugin, potentially executing privileged operations.","url":"https://insights.sbomify.com/CVE-2026-35645/"}