CVE-2026-35646 OpenClaw < 2026.3.25 - Pre-Authentication Rate-Limit Bypass in Webhook Token Validation
Attackers can bypass rate limits to brute-force weak webhook tokens, potentially gaining unauthorized access to OpenClaw services.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-35646?
CVE-2026-35646 is a medium-severity vulnerability in Openclaw Openclaw, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
OpenClaw before 2026.3.25 contains a pre-authentication rate-limit bypass vulnerability in webhook token validation that allows attackers to brute-force weak webhook secrets. The vulnerability exists because invalid webhook tokens are rejected without throttling repeated authentication attempts, enabling attackers to guess weak tokens through rapid successive requests.
Weakness: CWE-307
Which versions are affected by CVE-2026-35646?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.3.28 |
openclaw npm | All versions | 2026.3.28 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-35646?
Upgrade openclaw to 2026.3.28 or later.
Is CVE-2026-35646 being exploited?
There is no known exploitation of CVE-2026-35646 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-mf5g-6r6f-ghhm, MINI-x98x-4f9m-r5v9.