CVE-2026-35648 OpenClaw < 2026.3.22 - Policy Bypass via Unvalidated Queued Node Actions
Attackers can execute unauthorized commands by exploiting stale allowlists in queued node actions that bypass current policy checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-35648?
CVE-2026-35648 is a low-severity vulnerability in Openclaw Openclaw, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenClaw before 2026.3.22 contains a policy bypass vulnerability where queued node actions are not revalidated against current command policy when delivered. Attackers can exploit stale allowlists or declarations that survive policy tightening to execute unauthorized commands.
Weakness: CWE-367
Which versions are affected by CVE-2026-35648?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.3.22 |
openclaw npm | All versions | 2026.3.22 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-35648?
Upgrade openclaw to 2026.3.22 or later.
Is CVE-2026-35648 being exploited?
There is no known exploitation of CVE-2026-35648 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-wj55-88gf-x564, MINI-ch34-x32h-xvwh.