CVE-2026-35650 OpenClaw < 2026.3.22 - Environment Variable Override Bypass via Inconsistent Sanitization
Attackers can bypass environment variable sanitization in OpenClaw to execute arbitrary code with unintended environment variables.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-35650?
CVE-2026-35650 is a high-severity vulnerability in Openclaw Openclaw, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenClaw before 2026.3.22 contains an environment variable override handling vulnerability that allows attackers to bypass the shared host environment policy through inconsistent sanitization paths. Attackers can supply blocked or malformed override keys that slip through inconsistent validation to execute arbitrary code with unintended environment variables.
Weakness: CWE-15
Which versions are affected by CVE-2026-35650?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.3.22 |
openclaw npm | All versions | 2026.3.22 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-35650?
Upgrade openclaw to 2026.3.22 or later.
Is CVE-2026-35650 being exploited?
There is no known exploitation of CVE-2026-35650 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-39pp-xp36-q6mg, MINI-2hfh-v4vc-4h76.