CVE-2026-35651 OpenClaw 2026.2.13 < 2026.3.25 - ANSI Escape Sequence Injection in Approval Prompt

Medium 5.3 Published Updated

Attackers can inject ANSI escape sequences to spoof terminal output in approval prompts, potentially bypassing security checks in OpenClaw.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-35651?

CVE-2026-35651 is a medium-severity vulnerability in Openclaw Openclaw, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

OpenClaw versions 2026.2.13 through 2026.3.24 contain an ANSI escape sequence injection vulnerability in approval prompts that allows attackers to spoof terminal output. Untrusted tool metadata can carry ANSI control sequences into approval prompts and permission logs, enabling attackers to manipulate displayed information through malicious tool titles.

Weakness: CWE-150

Which versions are affected by CVE-2026-35651?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmFrom 2026.2.132026.3.28
openclaw npmFrom 2026.2.132026.3.28

Products include Openclaw Openclaw.

How do I fix CVE-2026-35651?

Upgrade openclaw to 2026.3.28 or later.

Is CVE-2026-35651 being exploited?

There is no known exploitation of CVE-2026-35651 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-4hmj-39m8-jwc7, MINI-grrx-hrjr-983h.

Is CVE-2026-35651 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free