CVE-2026-35664 OpenClaw < 2026.3.25 - DM Pairing Bypass via Legacy Card Callbacks

Medium 6.9 Published Updated

Attackers can bypass DM pairing restrictions to send raw card commands and reach callback handling without authorization in OpenClaw.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-35664?

CVE-2026-35664 is a medium-severity authentication bypass vulnerability in Openclaw Openclaw, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenClaw before 2026.3.25 contains an authentication bypass vulnerability in raw card send surface that allows unpaired recipients to mint legacy callback payloads. Attackers can send raw card commands to bypass DM pairing restrictions and reach callback handling without proper authorization.

Weakness: CWE-288

Which versions are affected by CVE-2026-35664?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmAll versions2026.3.28
openclaw npmAll versions2026.3.28

Products include Openclaw Openclaw.

How do I fix CVE-2026-35664?

Upgrade openclaw to 2026.3.28 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-35664 being exploited?

There is no known exploitation of CVE-2026-35664 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-77w2-crqv-cmv3, MINI-6x3q-42j2-f6xx.

Is CVE-2026-35664 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free