{"answers":{"affected":"4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35671 exists.","fix":"Upgrade thorsten/phpmyfaq to 4.1.3 or later.","what":"CVE-2026-35671 is a high-severity missing authorization vulnerability in thorsten phpMyFAQ, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-35671 and fix it if it is affected.\n\nWhat it is: CVE-2026-35671 is a high-severity missing authorization vulnerability in thorsten phpMyFAQ, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35671 exists.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.3\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.3\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.3\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-35671/ (Markdown: https://insights.sbomify.com/CVE-2026-35671/index.md)","id":"CVE-2026-35671","markdown":"https://insights.sbomify.com/CVE-2026-35671/index.md","name":"CVE-2026-35671","record":{"aliases":["GHSA-xvp4-phqj-cjr3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"FAQ web application","requires_auth":"low_privilege","summary":"Authenticated low-privilege admins can escalate to SuperAdmin by modifying the userId parameter in the password API, allowing unauthorized password changes.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"phpMyFAQ before 4.1.3 contains an insecure direct object reference vulnerability in the admin API user password endpoint that allows authenticated administrators to change any user's password without authorization verification. An attacker with low-privilege admin credentials can escalate to SuperAdmin by modifying the userId parameter in the overwrite-password API request.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ - Insecure Direct Object Reference in User Password API","id":"CVE-2026-35671","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"phpMyFAQ - Authentication Bypass via Empty API Token","id":"CVE-2026-35672"},"packages":[{"ecosystem":"Packagist","fixed":["4.1.3"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-xvp4-phqj-cjr3"},{"ecosystem":"Packagist","fixed":["4.1.3"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-xvp4-phqj-cjr3"},{"ecosystem":"Packagist","fixed":["4.1.3"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-xvp4-phqj-cjr3"},{"ecosystem":"Packagist","fixed":["4.1.3"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-xvp4-phqj-cjr3"}],"prev":{"headline":"OpenClaw \u003c 2026.3.22 - Webhook Reply Rebinding via Username Resolution in Synology Chat","id":"CVE-2026-35670"},"products":["phpMyFAQ"],"published":"2026-05-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["thorsten"]},"summary":"Authenticated low-privilege admins can escalate to SuperAdmin by modifying the userId parameter in the password API, allowing unauthorized password changes.","url":"https://insights.sbomify.com/CVE-2026-35671/"}