# CVE-2026-35675: phpMyFAQ - Authentication Bypass via Missing Password Reset Token in /api/user/password/update

> Unauthenticated attackers can bypass password reset verification to take over any user account, including administrators, in phpMyFAQ.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-w9xh-5f39-vq89

## What is CVE-2026-35675?

CVE-2026-35675 is a high-severity authentication bypass vulnerability in thorsten phpMyFAQ, published on 28 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpMyFAQ before 4.1.3 contains an authentication bypass vulnerability in the password reset endpoint that allows unauthenticated attackers to reset any user account password without token verification or email confirmation. Attackers can enumerate valid usernames, obtain plaintext passwords via email, and achieve complete account takeover including administrative access.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-35675?

4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.3 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.3 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.3 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.3 |

## How do I fix CVE-2026-35675?

Upgrade thorsten/phpmyfaq to 4.1.3 or later.

## Is CVE-2026-35675 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35675 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35675 and fix it if it is affected.

What it is: CVE-2026-35675 is a high-severity authentication bypass vulnerability in thorsten phpMyFAQ, published on 28 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35675 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.3
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.3
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.3
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35675/ (Markdown: https://insights.sbomify.com/CVE-2026-35675/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35675
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35675
- OSV: https://osv.dev/vulnerability/CVE-2026-35675

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35675/
Summaries are generated and may contain mistakes; the official description above is the record.
