{"answers":{"affected":"4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35676 exists.","fix":"Upgrade thorsten/phpmyfaq to 4.1.3 or later.","what":"CVE-2026-35676 is a high-severity authentication bypass vulnerability in thorsten phpMyFAQ, published on 28 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-35676 and fix it if it is affected.\n\nWhat it is: CVE-2026-35676 is a high-severity authentication bypass vulnerability in thorsten phpMyFAQ, published on 28 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35676 exists.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.3\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.3\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.3\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-35676/ (Markdown: https://insights.sbomify.com/CVE-2026-35676/index.md)","id":"CVE-2026-35676","markdown":"https://insights.sbomify.com/CVE-2026-35676/index.md","name":"CVE-2026-35676","record":{"aliases":["GHSA-9qv9-8xv6-5p35"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"FAQ web application","requires_auth":"none","summary":"Unauthenticated attackers can reset user passwords via the API, leading to account takeover and denial of service.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-640","name":"Weak Password Recovery Mechanism for Forgotten Password"}],"description":"phpMyFAQ before 4.1.3 contains an unauthenticated password reset vulnerability in the user password update API endpoint that allows attackers to change account passwords without token validation. Attackers can enumerate valid username and email pairs and force immediate password changes by sending PUT requests to the /api/index.php/user/password/update endpoint, causing account disruption and invalidating legitimate user credentials.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ - Unauthenticated Password Reset via User Password Update Endpoint","id":"CVE-2026-35676","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"Business logic in zcashd","id":"CVE-2026-35679"},"packages":[{"ecosystem":"Packagist","fixed":["4.1.3"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-9qv9-8xv6-5p35"},{"ecosystem":"Packagist","fixed":["4.1.3"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-9qv9-8xv6-5p35"},{"ecosystem":"Packagist","fixed":["4.1.3"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-9qv9-8xv6-5p35"},{"ecosystem":"Packagist","fixed":["4.1.3"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-9qv9-8xv6-5p35"}],"prev":{"headline":"phpMyFAQ - Authentication Bypass via Missing Password Reset Token in /api/user/password/update","id":"CVE-2026-35675"},"products":["phpMyFAQ"],"published":"2026-05-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["thorsten"]},"summary":"Unauthenticated attackers can reset user passwords via the API, leading to account takeover and denial of service.","url":"https://insights.sbomify.com/CVE-2026-35676/"}