# CVE-2026-3590: Race Condition in Guest Magic Link Authentication Allows Token Reuse

> Attackers can reuse guest magic link tokens concurrently to establish multiple authenticated sessions, bypassing single-use restrictions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** GHSA-mh4x-rmrx-3hp4, GO-2026-5507

## What is CVE-2026-3590?

CVE-2026-3590 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mattermost versions 10.11.x <= 10.11.12, 11.5.x <= 11.5.0, 11.4.x <= 11.4.2, 11.3.x <= 11.3.2 fail to enforce atomic single-use consumption of guest magic link tokens, which allows an attacker with access to a valid magic link to establish multiple independent authenticated sessions via concurrent requests.. Mattermost Advisory ID: MMSA-2026-00624

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-3590?

14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0-rc1 | 10.11.13 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0-rc1 | 10.11.13 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0-rc1+incompatible | 10.11.13+incompatible, 11.3.3+incompatible, 11.4.3+incompatible, 11.5.0+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 11.3.0-rc1 | 11.3.3 |
| `github.com/mattermost/mattermost-server` | Go | From 11.3.0-rc1 | 11.3.3 |
| `github.com/mattermost/mattermost-server` | Go | From 11.4.0-rc1 | 11.4.3 |
| `github.com/mattermost/mattermost-server` | Go | From 11.4.0-rc1 | 11.4.3 |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0-rc1 | 11.5.0 |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0-rc1 | 11.5.0 |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20250721062209-4952acea88ce | 8.0.0-20250723052842-4cb8d8940332 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20250721062209-4952acea88ce | 8.0.0-20250723052842-4cb8d8940332 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20250721062209-4952acea88ce | 8.0.0-20250723052842-4cb8d8940332 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-3590?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.13, 10.11.13+incompatible, 11.3.3+incompatible or 11.4.3+incompatible.

## Is CVE-2026-3590 being exploited?

There is no known exploitation of CVE-2026-3590 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-3590 and fix it if it is affected.

What it is: CVE-2026-3590 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-3590 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0-rc1; fixed in 10.11.13
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0-rc1; fixed in 10.11.13
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0-rc1+incompatible; fixed in 10.11.13+incompatible, 11.3.3+incompatible, 11.4.3+incompatible, 11.5.0+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 11.3.0-rc1; fixed in 11.3.3
- github.com/mattermost/mattermost-server (Go): affected from 11.3.0-rc1; fixed in 11.3.3
- github.com/mattermost/mattermost-server (Go): affected from 11.4.0-rc1; fixed in 11.4.3
- github.com/mattermost/mattermost-server (Go): affected from 11.4.0-rc1; fixed in 11.4.3
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0-rc1; fixed in 11.5.0
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0-rc1; fixed in 11.5.0
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 8.0.0-20250721062209-4952acea88ce; fixed in 8.0.0-20250723052842-4cb8d8940332

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-3590/ (Markdown: https://insights.sbomify.com/CVE-2026-3590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-3590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-3590
- OSV: https://osv.dev/vulnerability/CVE-2026-3590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-3590/
Summaries are generated and may contain mistakes; the official description above is the record.
