{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-3610 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-3610 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-3610 is a medium-severity cross-site scripting vulnerability in HSC Cybersecurity Mailinspector, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-3610 and fix it if it is affected.\n\nWhat it is: CVE-2026-3610 is a medium-severity cross-site scripting vulnerability in HSC Cybersecurity Mailinspector, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-3610 in the wild and no public exploit code.\n\nAffected product: HSC Cybersecurity Mailinspector. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-3610/ (Markdown: https://insights.sbomify.com/CVE-2026-3610/index.md)","id":"CVE-2026-3610","markdown":"https://insights.sbomify.com/CVE-2026-3610/index.md","name":"CVE-2026-3610","record":{"aliases":["GHSA-rgc7-cqpm-cvh8"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Mailinspector email security","requires_auth":"none","summary":"Remote attackers can execute arbitrary scripts via the error_description parameter in Mailinspector, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in HSC Cybersecurity Mailinspector up to 5.3.2-3. Affected by this issue is some unknown functionality of the file /mailinspector/mliUserValidation.php of the component URL Handler. The manipulation of the argument error_description results in cross site scripting. The attack may be performed from remote. The exploit has been made public and could be used. Upgrading to version 5.4.0 can resolve this issue. You should upgrade the affected component. The vendor was contacted early and responded very professional: \"We have already implemented the fix and made a hotfix available to affected customers, ensuring mitigation while the official release 5.4.0 has not yet been published. This allows customers to address the issue immediately, outside the regular release cycle.\"","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"HSC Cybersecurity Mailinspector URL mliUserValidation.php cross site scripting","id":"CVE-2026-3610","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Honeywell IQ4x BMS Controller Missing authentication for critical function","id":"CVE-2026-3611"},"packages":[],"prev":{"headline":"XIGNCODE3 xhunter1.sys kernel driver contains a Privilege Escalation Vulnerability","id":"CVE-2026-3609"},"products":["Mailinspector"],"published":"2026-03-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-09","vendors":["HSC Cybersecurity"]},"summary":"Remote attackers can execute arbitrary scripts via the error_description parameter in Mailinspector, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2026-3610/"}