# CVE-2026-3610: HSC Cybersecurity Mailinspector URL mliUserValidation.php cross site scripting

> Remote attackers can execute arbitrary scripts via the error_description parameter in Mailinspector, potentially leading to session hijacking or code execution.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 6 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-rgc7-cqpm-cvh8

## What is CVE-2026-3610?

CVE-2026-3610 is a medium-severity cross-site scripting vulnerability in HSC Cybersecurity Mailinspector, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in HSC Cybersecurity Mailinspector up to 5.3.2-3. Affected by this issue is some unknown functionality of the file /mailinspector/mliUserValidation.php of the component URL Handler. The manipulation of the argument error_description results in cross site scripting. The attack may be performed from remote. The exploit has been made public and could be used. Upgrading to version 5.4.0 can resolve this issue. You should upgrade the affected component. The vendor was contacted early and responded very professional: "We have already implemented the fix and made a hotfix available to affected customers, ensuring mitigation while the official release 5.4.0 has not yet been published. This allows customers to address the issue immediately, outside the regular release cycle."

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-3610?


## How do I fix CVE-2026-3610?

No fix has been published for CVE-2026-3610 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-3610 being exploited?

There is no known exploitation of CVE-2026-3610 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-3610 and fix it if it is affected.

What it is: CVE-2026-3610 is a medium-severity cross-site scripting vulnerability in HSC Cybersecurity Mailinspector, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-3610 in the wild and no public exploit code.

Affected product: HSC Cybersecurity Mailinspector. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-3610/ (Markdown: https://insights.sbomify.com/CVE-2026-3610/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-3610
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-3610
- OSV: https://osv.dev/vulnerability/CVE-2026-3610

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-3610/
Summaries are generated and may contain mistakes; the official description above is the record.
