{"answers":{"affected":"2 open source packages ship an affected version, including krayin/laravel-crm.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-36340 exists.","fix":"Upgrade krayin/laravel-crm to 2.1.6 or later.","what":"CVE-2026-36340 is a high-severity code injection vulnerability in n/a, published on 30 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-36340 and fix it if it is affected.\n\nWhat it is: CVE-2026-36340 is a high-severity code injection vulnerability in n/a, published on 30 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-36340 exists.\n\nAffected packages and fixed versions:\n- krayin/laravel-crm (Packagist): affected from 2.1.5; fixed in 2.1.6\n- krayin/laravel-crm (Packagist): affected from 2.1.5; fixed in 2.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-36340/ (Markdown: https://insights.sbomify.com/CVE-2026-36340/index.md)","id":"CVE-2026-36340","markdown":"https://insights.sbomify.com/CVE-2026-36340/index.md","name":"CVE-2026-36340","record":{"aliases":["GHSA-32px-ccfx-cxq3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Krayin CRM","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary code via the compose email function in Krayin CRM, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"An issue in Krayin CRM v.2.1.5 and fixed in v.2.1.6 allows a remote attacker to execute arbitrary code via the compose email function","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2026-04-30","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-04-30T01:39:09Z","kind":"github_poc","ref":"https://github.com/cybercrewinc/CVE-2026-36340","stars":2,"title":"Remote Code Execution (RCE) Vulnerability in Krayin CRM v2.1.5"}],"tier":"weaponised"},"has_fix":true,"headline":"Krayin CRM allows a remote attacker to execute arbitrary code via compose email function","id":"CVE-2026-36340","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Webkul Krayin CRM is Vulnerable to Cross-Site Scripting in the /admin/activities/create endpoint","id":"CVE-2026-36341"},"packages":[{"ecosystem":"Packagist","fixed":["2.1.6"],"introduced":["2.1.5"],"last_affected":[],"package":"krayin/laravel-crm","purl":null,"source":"GHSA-32px-ccfx-cxq3"},{"ecosystem":"Packagist","fixed":["2.1.6"],"introduced":["2.1.5"],"last_affected":[],"package":"krayin/laravel-crm","purl":"pkg:composer/krayin/laravel-crm","source":"GHSA-32px-ccfx-cxq3"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2026-36324"},"products":["n/a"],"published":"2026-04-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-30","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via the compose email function in Krayin CRM, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2026-36340/"}