# CVE-2026-36340: Krayin CRM allows a remote attacker to execute arbitrary code via compose email function

> Remote attackers can execute arbitrary code via the compose email function in Krayin CRM, requiring an upgrade to the latest version.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2026
- **Updated:** 30 Apr 2026
- **Also known as:** GHSA-32px-ccfx-cxq3

## What is CVE-2026-36340?

CVE-2026-36340 is a high-severity code injection vulnerability in n/a, published on 30 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue in Krayin CRM v.2.1.5 and fixed in v.2.1.6 allows a remote attacker to execute arbitrary code via the compose email function

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-36340?

2 open source packages ship an affected version, including krayin/laravel-crm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `krayin/laravel-crm` | Packagist | From 2.1.5 | 2.1.6 |
| `krayin/laravel-crm` | Packagist | From 2.1.5 | 2.1.6 |

## How do I fix CVE-2026-36340?

Upgrade krayin/laravel-crm to 2.1.6 or later.

## Is CVE-2026-36340 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-36340 exists.

Public exploit code:

- Remote Code Execution (RCE) Vulnerability in Krayin CRM v2.1.5 (github_poc): https://github.com/cybercrewinc/CVE-2026-36340

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-36340 and fix it if it is affected.

What it is: CVE-2026-36340 is a high-severity code injection vulnerability in n/a, published on 30 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-36340 exists.

Affected packages and fixed versions:
- krayin/laravel-crm (Packagist): affected from 2.1.5; fixed in 2.1.6
- krayin/laravel-crm (Packagist): affected from 2.1.5; fixed in 2.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-36340/ (Markdown: https://insights.sbomify.com/CVE-2026-36340/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-36340
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-36340
- OSV: https://osv.dev/vulnerability/CVE-2026-36340

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-36340/
Summaries are generated and may contain mistakes; the official description above is the record.
